[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installing debian, dual boot on 1 TB disk?

Hash: SHA1

You're welcome :)

I'm happy to help when I can.

On 06.02.2012 19:33, Arief M Utama wrote:
> On 02/07/2012 12:23 AM, Mika Suomalainen wrote: On 06.02.2012
> 19:06, Arief M Utama wrote:
>>>> Hi Mika,
>>>> First, thank you for your reply,
>>>> On 02/07/2012 12:03 AM, Mika Suomalainen wrote: Hi,
>>>> I think that I had same problem some time ago. First I
>>>> shrinked Windows partition with gparted on Ubuntu* CD. When I
>>>> tried to create new partition for Debian, it said something
>>>> like "You have too many primary partitions. The maximum of
>>>> primary partitions is 4. You can create multiple partitions
>>>> by removing one partition and creating a new 'extended
>>>> partition'. I did this and I was able to create partition for
>>>> Debian and swap partition.
>>>>> May I know what is the size of your disk?
> 465.76 GIB
>>>>> My problem is I can't do anything at all to that "free"
>>>>> space, there's nothing I could use to create any type of
>>>>> partition there. Hmm, or there is :-) Maybe I could try
>>>>> fdisk and see how it goes, I totally forgot about this.
> I had that problem too. Every time when I tried, it gave that
> error message which I said previously. I was able to create
> partitions from that free space after I removed the recovery
> partition and made extended partition on it's place. To that
> partition I have been able to create more.
>> Yess, Mika, you are right.
>> Thanks for your help, I really appreciate it :-)
>> All the best. -arief
> My partition table in gparted currently looks like this: Partition
> Filesystem    Table    (used, free and flags aren't probably needed
> and I am too lazy to write them) /dev/sda1    ntfs    SYSTEM (This
> is probably that "Windows-helper" partition, I don't know). 
> /dev/sda2    ntfs /dev/sda3    extended /dev/sda5    linux-swap 
> /dev/sda6    ext4 unallocated    unallocated /dev/sda4    fat32
> HP_TOOLS unallocated unallocated
>>>>> Thanks for the pointer!
>>>>> All the best. -arief
>>>> (*I'm not familiar with text mode install partitioning which 
>>>> Debian uses so I used gparted in Ubuntu CD to make sure that
>>>> I won't accidentally remove Windows partition.)
>>>> I hope that this helps. On 06.02.2012 18:36, Arief M Utama
>>>> wrote:
>>>>>>> Hi all,
>>>>>>> I thought I'm already a veteran user until I discovered
>>>>>>> I know almost nothing about this problem today  :-D
>>>>>>> Got a problem here, I have a laptop with
>>>>>>> pre-installed windows, the partition scheme is
>>>>>>> more-or-less like this:
>>>>>>> - 100M partition (hidden) - seems like a
>>>>>>> Windows-helper partition (I read something about it,
>>>>>>> forgotten now) - ~960 GB Windows partition - ~20GB
>>>>>>> Recovery partion -  ~10M another part of recovery
>>>>>>> partition
>>>>>>> When I tried to install debian, What I did was
>>>>>>> shrinking the 960GB partition to ~900GB, then I thought
>>>>>>> I could have ~60GB for linux.
>>>>>>> But then it said the free space is unusable, I cant do
>>>>>>> any partitioning on it.
>>>>>>> Anyone familiar with this problem? Is this something to
>>>>>>> do about the partition table can't handle large disk
>>>>>>> size issue?
>>>>>>> Any help and pointers are appreciated.
>>>>>>> Please CC me on your replies as I am not subscribed to 
>>>>>>> debian-user currently.
>>>>>>> Thanks :-)
>>>>>>> All the best. -arief
>>>> -- Mika Suomalainen
>>>>>>> gpg --keyserver keyserver.ubuntu.com --recv-keys
>>>>>>> 03D41B0D C0151D5C gpg --keyserver keyserver.ubuntu.com
>>>>>>> --recv-keys 8751C396
> -- Mika Suomalainen
>>>> gpg --keyserver keyserver.ubuntu.com --recv-keys 03D41B0D
>>>> C0151D5C gpg --keyserver keyserver.ubuntu.com --recv-keys
>>>> 8751C396

- -- 
Mika Suomalainen
> gpg --keyserver keyserver.ubuntu.com --recv-keys 03D41B0D C0151D5C 
> gpg --keyserver keyserver.ubuntu.com --recv-keys 8751C396
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/


Reply to: