[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Upgrading to Iceweasel 10 in Squeeze

Rob Hurle wrote:
> debianrob:/etc/apt# apt-cache policy libnss3-1d
> libnss3-1d:
>   Installed: 3.12.8-1+squeeze4
>   Candidate: 3.12.8-1+squeeze4
>   Version table:
>      3.13.1.with.ckbi.1.88-1~bpo60+1 0
>         100 http://backports.debian.org/debian-backports/ squeeze-backports/main i386 Packages
>  *** 3.12.8-1+squeeze4 0
>         500 http://ftp.au.debian.org/debian/ squeeze/main i386 Packages
>         500 http://security.debian.org/ squeeze/updates/main i386 Packages
>         100 /var/lib/dpkg/status

What?  That doesn't make sense.  The clue is there but I am unable to
interpret the data in any way that makes sense to me.  But hopefully
someone else will be able to diagnose it from there.

> I guess the "100" "500" etc have to do with pinning?  But I'm not sure
> where to look for this.

Yes.  See the man page for apt_preferences(5) for an explanation of
pinning.  But your preference numbers look okay.  They match what I
have here and my systems were able to upgrade normally.

Read the man page for apt_preferences and perhaps upon reading it the
answer will be apparent to you.

Hopefully you do not have any preferences files installed at all.
Hopefully this following returns nothing found.

  find /etc/apt/preferences* -type f -print

In spite of other problems you should be able to install the package
manually by using an explicit request for it.  But this shouldn't be
needed and I think it would be better for you to determine why your
system is broken rather than cover up the problem.

  apt-get install libnss3-1d=3.13.1.with.ckbi.1.88-1~bpo60+1

> Does this indicate that version 3.12.8-1 of libnss3-1d has been
> installed and pinned?  How can I find out why that version is
> installed, and how can I I change this?

To be correct it says that 3.12.8-1+squeeze4 has been installed not
3.12.8-1.  Version 3.12.8-1 would be older than 3.12.8-1+squeeze4.

>   Installed: 3.12.8-1+squeeze4
>   Candidate: 3.12.8-1+squeeze4

And it says that 3.12.8-1+squeeze4 is the candidate for an upgrade.
Since they are the same the isn't any work to do.  But there is also:

>      3.13.1.with.ckbi.1.88-1~bpo60+1 0
>         100 http://backports.debian.org/debian-backports/ squeeze-backports/main i386 Packages

That looks okay.  It is noting that there is a newer version
3.13.1.with.ckbi.1.88-1~bpo60+1 available from backports with a
preference of 100.  This is high priority than 3.12.8-1+squeeze4 and
so therefore 3.12.8-1+squeeze4 should be the candidate but it isn't.

The question is, why not?  Keep digging.  Something has been modified
on your system which is causing this discrepancy.  Usually it is the
local admin that has done this.  :-)

Make sure that you have run 'apt-get update' to update the lists.


Attachment: signature.asc
Description: Digital signature

Reply to: