[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Etch to 5.0.2 upgrade failed - Encrypted filesystem will not boot

On Wednesday 05 August 2009 19:54:50 lineman@ruiner.halo.nu wrote:
> I tried configuring fstab to use the UUID from blkid, but I had the same
> problem.  Could the problem be that the SCSI drives are not coming up until
> cryptsetup has loaded?

  Hi again lineman (and list).

  Just for another data-point, I have just now finished
upgrading my laptop, with the dm-crypt-encrypted hard
drive, from etch to lenny.  There were several minor
issues with packages, but the crypto part worked fine.

  (Anticipating doing this myself is part of why I
was following this thread...)

  I *do* see the "Driver 'sd' needs updating" message,
but my system boots, so that's apparently unrelated.

  My /etc/fstab file doesn't use UUIDs, it lists the
device-mapper names of all the devices, and it works.
This shouldn't matter in any case for the root FS, it's
mounted before /etc/fstab is read, and the device name 
is taken from the kernel args.

  I tried booting with the "break" boot option, which drops
you into the busybox shell at the init-premount step, and
tried to see if I could manually set up the crypto, but it's
a bit complicated, and relies on environment variables which
are set for the scripts, but apparently not set in the shell.

  One thing you *can* do easily is, boot with the "break" 
option, and from within the resulting shell, run 
/scripts/init-premount/udev, which will create all the devices.  
You can then do an "ls" in /dev, and see if the relevant 
hard drive partition (/dev/sda5, in your case) is are present -- 
this tests the udev step pretty directly.

  Hope this helps.  

				-- A.
Andrew Reid / reidac@bellatlantic.net

Reply to: