[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: How to change console font?

On Mon, Mar 2, 2009 at 10:14, Robert Latest <boblatest@googlemail.com> wrote:
> Hello there,
> I'm completely stumped. I'm using the out-of-the-box lenny kernel
> vmlinuz-2.6.26-1-686. According to the config file, ehere seem to be
> many framebuffer options hard-compiled into the kernel (seel below).
> When I set the "vga=ask" kernel option, all I get is a handful of
> chunky 80-by-something options. Selecting "scan" doesn't reveal
> anything new. All of the modes listed in the "framebuffer HOWTO" yield
> a "video mode unavailable" error. Yes I know I can't just enter
> numeric modes at the prompt, I've also tried them in the command line,
> decimal, hexadecimal, it doesn't matter.
> What's going on here? When I boot a KNOPPIX cd I get the framebuffer,
> so it can't be a hardware issue.
> BTW, on the vmlinuz-2.6.18-6-k7 I used to use mode 775 which doesn't
> seem to be a fb mode because it doesn't have the penguin logo.

As far as I know, any mode other than 80x25 is FB. There are two
way to display a penguin, one is the kernel option for a boot logo
(off by default in debian), the other is a boot splash program, such
as splashy or usplash.

All I do to enable higher resolution fb modes is put "vga=791" in the
kernel boot options and make sure console-setup is installed. I am
pretty stumped as to why this isn't working for you.

This clears up the mode numbers a little bit:

On Mon, Mar 2, 2009 at 10:26, Robert Latest <boblatest@googlemail.com> wrote:
> Another curious thing: I tried to make some framebuffer devices in
> /dev (as described in the HOWTO), but they get deleted on reboot!
> Since when gets stuff deleted from /dev?

Since 2.6.0, if you are are using udev (which is the default).
You don't have to make the fb device, that howto is pretty old.

Kelly Clowers

Reply to: