[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Resp.: drbd WAS working fine; but now fsck can't open /dev/drbd? ??

Hi Bob,

I can't help you with your trouble, but I'm interested in drbd, can
you post your cenario? I'll test it.



2008/7/16, Bob <bobg.hahc@gmail.com>:
> As a followup to my own post -
> I've since tried inserting drbd into /etc/modules, and /etc/initramfs-
> tools/modules (and updated initramfs).
> But nothing I do seems to cause the drbd module to load prior to fsck
> running..
> (I do have drbd0.7-module-source  installed) and the module DOES load
> & work fine, if I manually continue past the boot issue.
> Any other thoughts/suggestions?
> TIA - Bob
> On Jul 14, 1:00 pm, Bob <bobg.h...@gmail.com> wrote:
>> running debian etch; drbd v0.7; along with HA; under ext3 filesystems;
>> both system were running fine, and drbd work working great.
>> assuming there was a power outage, now when I bring up the primary
>> system I get (during boot):
>> fsck.ext3: no such file or directory while trying to open /dev/drbd0
>> the superblock could not be read or does not describe a correct ext2
>> filesystem.
>> fsck died with exit status 8    ....[snip]... superblock may be
>> corrupt.
>> <<
>> /dev/drbd0 is drbd's device to /dev/sdb1; which DOES fsck PERFECTLY.
>> this system isn't even coming up to runlevel 2...  going into maint.
>> mode....
>> i've tried ef2check -f and it shows filesys clean... (again on /dev/
>> sdb1)
>> /dev/drbd0 doesn't exist until drbd is loaded; but if I load drbd,
>> there's no way I can fsck /dev/drbd0 because "it's busy".
>> anyone have any idea's ??
>> TIA - Bob
>> --
>> To UNSUBSCRIBE, email to debian-user-REQU...@lists.debian.org
>> with a subject of "unsubscribe". Trouble? Contact
>> listmas...@lists.debian.org
> --
> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact
> listmaster@lists.debian.org

Reply to: