[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Transitioning to 64bit, is it worth it, and how

On 8/4/07, Alan Chandler <alan@chandlerfamily.org.uk> wrote:
I have a Core2 Duo on which I am running a 686 kernel (from Debian
unstable). It has 1GB of memory I am wondering two things
a) What are the pros and cons in switching to 64 bit mode?
        - Is it faster?

I am only responding to this particular message in the thread because my computer is still not fully operational and this is the only way (at the moment) to comment on this process. The whole process has been a nightmare - and not really anything to do with 64 bit architecture - although I haven't yet got to the point of finding out how to run flash in IceWeasel and Konqueror I had a raid 1 setup with a 32M /boot partition, a 4G / partition and a large LVM on raid 1 partition for the rest (except swap - which takes equal space on my two drives). The drives are SATA - originally on /dev/sda and /dev/sdb I used the debian netinst disk from this weeks lenny. Firstly I wanted to increase /boot from 32M to 100M because I kept getting disk full on upgrades. So in the installer I deleted the /boot and swap partitions and recreated them. For reasons I don't understand - although the old raid devices had both /dev/md[12] and /dev/md/[12] entries the new boot only had a /dev/md3 entry. However the installation seem to go well until it ran grub to install the boot sector. Thie "appeared" to work. However, as soon as I tried rebooting this new system the BIOS told me it couldn't find a boot disk. Everywhere I searched on the net, there is plenty of people who claim it does work - and with examples of what to do. I tried them all - but none worked. I even tried lilo - but I couldn't get that to work either. After much frustration I decided to just try installing the new system without raid on root and boot partitions. This is where the problem with the /dev/md3 entry wouldn't work because the partitioner failed to allow me to delete this device. Again after much frustration I created a symlink /dev/md/3 to /dev/md3 and was able to make it work. So I installed a system where / and /boot are not on raid and low and behold grub seemed to successfully install the boot sector and I could boot the disks. However I now hit the next problem = the installer somehow thought my drives were /dev/sde and /dev/sdf (rather than /dev/sda and /dev/sdb that they originally were) so created /etc/fstab, and the grub menu.lst entries refering to these drives. However when booting the new system it expected /dev/sda and /dev/sdb and so root failed to mount. I had to go back into the installer and manually edit files in the target system to make it work. I have been able to go back to raid - by using mdadm to create a raid 1 array with a missing entry and /dev/sdb[13] as the component devices. I mounted these as /dev/md1 and /dev/md3 and rsync'ed the contents of / (/dev/sda3) and /boot (dev/sda1) across to them. Editing in fstab and grub's menu.lst to reflect the change of devices and a reboot I had a system running on raid. Finally repartitioned /dev/sda[13] as raid autodetect partitions and added them into the existing arrays as the second device. I did make a big mistake at this point and forgot to
a) Update /etc/mdadm/mdadm.conf with the raid array details
b) Run update-initramfs So on next reboot I got bounced into a shell inside initramfs and had to manually assemble to raid arrays before I could carry on (and then correct that mistake). Hopefully when I get home from work this evening I can continue (can't get Xorg working - but I have a backup of my xorg.conf so that should solve this).

Alan Chandler
(via webmail - normally means I am not at my computer)

Reply to: