[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Since chvt works, the problem must be the keymap [SOLVED]

Andrew Sackville-West <andrew@farwestbilliards.com> wrote:
> On Tue, May 08, 2007 at 11:40:02PM -0400, Amy Templeton wrote:
> > Florian Kulzer <florian.kulzer+debian@icfo.es> wrote:
> > 
> > > What do you see if you disable your workaround, run
> > 
> > > tail -fn0 /var/log/Xorg.0.log
> > 
> > > and press CTRL+ALT+F1?
> > 
> > Well...if I do that while I'm still in the XTerm, I see...
> > 
> > ^[[1;7P

> that's not good. THat means X is ignoring those keystrokes and
> passing them through to Xterm.

> > ...but I think that's just XTerm freaking out. When another
> > frame is focused and I press the buttons, there is no output.

> the other frames provide no output because thety are ignoring
> key-presses they don't know how to deal with, I assume.

That seems about right, yeah.

> > One thing that I saw in the startx output using the "gb" layout
> > that I definitely do *not* see under the "us" layout was the
> > following...

> are you seeing this on the VT you launched X from or is it in the
> logs?

On the VT.

> > > If you get some errors or warnings related to switching
> > > graphics modes then we know that the key combination does
> > > work after all and that there is a problem with the graphics
> > > driver. If there is no output at all then we know that your
> > > keysyms are still not set up correctly.
> > 
> > It appears, then, to be the latter.
> > 
> > > It might also be illuminating to try if the switching works
> > > with the "gb" layout even if this layout is not an acceptable
> > > permanent solution.
> > 
> > Well, that's interesting. It did work properly using the "gb"
> > layout (though it took me a while to figure that out, since I
> > thought the keyboard wasn't working at all, but it turns out
> > there were just some problems until I disabled my xmodmap).
> > That's very weird.

> what happens when you disable your xmodmap with a "us" layout?

Oh dear...this is disturbing...it works properly. But...but...I
need to have Control where Caps Lock used to be, and I don't even
touch left-Alt! If xmodmap is the culprit, I'm afraid I'm just
going to have to deal with the problem. But at least, thanks to
you, the source of the problem has been found. Maybe I'll go
through at some point and comment out small portions at a time so I
can isolate the nefarious line(s) in question. But for now, I am
going to finish up the paper I'm ostensibly working on (no more
distracting self with email) and go to bed.

Thanks to all who've replied,

I can resist everything except temptation. -Oscar Wilde

Reply to: