[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: X-Windows Problems

On Mon, May 22, 2006 at 16:41:09 -0400, Thomas H. George wrote:
> I am stumbling through the move from Sarge to testing.  I have managed 
> to get gdm to start but if I switch to a console I lose the window and 
> must restart gdm.   Equally frustrating, my Wacom tablet mouse is not 
> recognized though it worked perfectly in Sarge and the wacom module is 
> installed.
> This may be because I have not yet installed x-window-system-core.  
> Apt-get reports that this package and 457 other packages are not 
> installed as they cannot be verified.  Should I go ahead and install 
> them anyway?

Which archive signing keys are known to your apt-key? Post the output of
"apt-key list" and the contents of your /etc/apt/sources.list file, then
we can tell you which ones are missing (and how to install them). I
would first try to complete the upgrade and install all packages before
addressing the X problem.


> Next I ran apt-get dist-upgrade.  After this the ethernet connection 
> failed, gdm tried to start repeatedly and failed and there was a message 
> that udev required kernel 2.6.12 or higher.  I had 2.6.11.
> Next I booted from a bbc-2.1 cd and used lynx to find and download the 
> linux-2.6.15 kernel source from the Debian website.  I compiled this 
> kernel using the .config from the 2.6.11 kernel directory, updated 
> lilo.conf, and booted from the new kernel.  The ethernet connection was 
> restored but gdm still would not start.  I tried dpkg-reconfigure 
> xserver-xfree86 without success.
> Next I recalled that previously I had solved this problem by running 
> xf86config from /usr/X11R6/bin.   The upgrade had deleted this program 
> but I recovered it from another computer and ran it.  This created an 
> XF86Config file in /etc/X11 and then gdm could start.

Testing is using Xorg instead of Xfree86. Once you have downloaded the
archive keys and completed the upgrade, you can try "dpkg-reconfigure
xserver-xorg". (This should happen automatically during the upgrade

If you still have problems with Xorg after that, post the output of the
following three commands:

lspci | grep -i vga
awk '/Section "(Device|Monitor|Screen)"/,/EndSection/' /etc/X11/xorg.conf
egrep '^\((EE|WW)\)' /var/log/Xorg.0.log


Reply to: