[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

X-Windows Problems

I am stumbling through the move from Sarge to testing. I have managed to get gdm to start but if I switch to a console I lose the window and must restart gdm. Equally frustrating, my Wacom tablet mouse is not recognized though it worked perfectly in Sarge and the wacom module is installed.

This may be because I have not yet installed x-window-system-core. Apt-get reports that this package and 457 other packages are not installed as they cannot be verified. Should I go ahead and install them anyway?

I know there have been many past messages on the list regarding the move from Sarge to testing and I will try to go back to the archives to see if this problem has already been solved repeatedly.

In the meantime if anyone has any quick words of advice they would be very welcome.

For the record, I started off by backing up all of my home directory and all of /etc.

Next I ran apt-get dist-upgrade. After this the ethernet connection failed, gdm tried to start repeatedly and failed and there was a message that udev required kernel 2.6.12 or higher. I had 2.6.11.

Next I booted from a bbc-2.1 cd and used lynx to find and download the linux-2.6.15 kernel source from the Debian website. I compiled this kernel using the .config from the 2.6.11 kernel directory, updated lilo.conf, and booted from the new kernel. The ethernet connection was restored but gdm still would not start. I tried dpkg-reconfigure xserver-xfree86 without success.

Next I recalled that previously I had solved this problem by running xf86config from /usr/X11R6/bin. The upgrade had deleted this program but I recovered it from another computer and ran it. This created an XF86Config file in /etc/X11 and then gdm could start.

It took me all day to get this far so I am posting this message and will resume the struggle tomorrow.

Tom George

Reply to: