[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Today's disaster with xorg update

Florian Kulzer wrote:
On Sat, Apr 15, 2006 at 12:50:43 -0400, nick lidakis wrote:
Florian Kulzer wrote:
I get the same error message, but X still starts for me, both with
"startx" from the console and with graphical log-in via kdm. Therefore I
would guess that you have an additional problem. Do you find any error
messages or warnings in the log files after you try to start X?

Try to run

egrep '^\((EE|WW)\)' /var/log/Xorg.0.log

Maybe that will turn up something useful to diagnose the problem.

I was able to get xorg started with your suggestion, but startx disregards my .xsession and tries to start twm (from /usr/lib/X11/xinit/xinitrc), whicj is not installed. I'm thinking I maybe deinstalled some package by mistake.

It might be important to know what the error messages or warnings were,
and what you did to get rid of them. If I remember correctly, you could
start Xorg 7.0 when we discussed about your whiteglass mouse cursor, so
what kind of problems did arise? Did you do another upgrade?

As a first, very general suggestion: Try to put your commands into
$HOME/.xinitrc and see if that takes precedence over whatever is in the
system-wide xinitrc. You could also try to reinstall the package

Upon suggestion from another post, I rm'ed /usr/X11R6/bin to allow for the dpkg configuration of x11-common to proceed; it did allow me to finish the installation of the package.

That has allowed me to get X running again but ( I do not use any login managers, I just type startx at the prompt; mostly I have had good luck with a simple hibernate script in bringing the machine back up) my .xsession is being ignored.

As far as I know (and have checked) I have not had a .xinitrc in my home directory for some time (is that bad??? don't flog me!).

My .xsession reads as follows:

bsetbg /home/nick/wallpaper/FrostyLeaves.png &
xset +dpms &
xset m 3 2 &
gkrellm -w &
xterm -fa fixed &
adesklets &

I have apt-get install --reinstall xbase-clients to no avail. X still won't recognize my .xsession.

BTW, thanks for your suggestion (in the previous post) regarding the x cursor; worked out fine.


Reply to: