[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Unable to write reliably CD-RW's!

On 04/04/06, G.C.H.M. Verhaag <verhaaggchm@ision.nl> wrote:
Vegard L. Rekaa wrote:

> ......
> My CD-burner is:
> Lite-On LTR48126S (I'm not at home so I'm guessing, but it is a pretty
> good guess)
> After doing all the configurations listed below this burner has worked
> perfectly!!
> If I should write a checklist on what I needed to fix, it would be:
>     - SCSI emulation (couldn't burn a working cd without this!!!)
>     - Set CDRECORD to SUID   (dpkg-reconfigure cdrecord)
>     - listen to all errormessages you may see when starting k3b, and
> fix them!
>     - Edit /etc/cdrecord/cdrecord so it  includes correct driver
> information.
>                 If you don't have this info, you can find burnerspecs
> on the web, use google.
>                 Sometimes it helps to set MAX_BURNERSPEED to less than
> the one given by
>                 the burner-specs. In my case I adjusted it down from
> 48x to 40x...
>     - Set rights to all devices needed for the cd-burner (these can be
> more than just one...)
>           with scsi emulation on my computer this was /dev/scd1 ,
> /dev/sg1 , /dev/cdrw  (just a symlink),
>           and make sure the devices is owned by a group you are a
> member of.
> .....
> Good luck!! If you need detailed explenations on this, say so and I
> will hand it to you when
> I am at home by the PC.
> Cheers, Vegard

Hoi Vegard,

Thanks for your detailed explanation! I can skip the k3b part because I
mainly use the plain cdrecord command, and sometimes xcdroast, also a
graphical frontend to cdrecord.

I've indeed gone through all the steps you mentioned and ran cdrecord as
root! I even reduced the writing speed to 2! Running cdrecord with the
-v option shows no errors at all. Using both the -v and -V option
results in more output, which shows some scsi errors after fixating, and
just before ejecting the disk! However I don't understand those messages!

I can't show you an example right now, because I removed the writer from
the Linux box, and have it checked for possible hardware problems.

By the way, is the Lite-On LTR-48126S a recent model that is still
available on the market?


If you still have these errormessages, post them here. There may be someone on this list who understands them.

I do not know wether LiteOn LTR48126S is still on the market. Try instead to look for an reasonable cd-writer on the market, post the name here and ask if anyone have any experiences, or any other cd-writer (still available) to recommend...

I will continue as if you still have your burner, just in case hardwarecheck gives no or positive result. Again, forgive me if I repeat things you allready have tried.

When you are trying to burn a cd is there anything burned at the cd at all, or is the cd still blank when finished?

A good check to see if cdrecord knows of your cd-burner is typing "cdrecord  -scanbus". If the output is a list wich contains your your cd-burner-device, try to burn a cd with the option "cdrecord dev=what_you_found cd_image.iso".    "what_you_found" could be 0,1,0    ,     0,0,0    ,   1,0,0  ,  2,0,0   etc (assuming you got a result from "cdrecord  -scanbus").

If "cdrecord  -scanbus" does not give any result, try "cdrecord dev=something -scanbus", where "something" can be any of these:   /dev/cdrw, /dev/scd0, /dev/scd1, /dev/cdrom0, /dev/cdrom1, 0,1,0 (etc), ATAPI:, ATA:     or something similar...

The moment you get an outpur listing your burner , say with dev=/dev/scd1, try to burn a cd with the command
    cdrecord dev=/dev/scd1 -v -speed=something_low image.iso

If all this fails, give us the errormesssages!

Again, good luck!
Salut, Vegard

Reply to: