[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Unable to write reliably CD-RW's!

On 04/04/06, G.C.H.M. Verhaag <verhaaggchm@ision.nl> wrote:
  Charlie wrote:

>I use only Lite-On CD/DVD burners, internal and USB external, in and plugged
>in, on desktops and laptops, and they work with Linux. Have always done, so
>when on a good thing, I stick to it.
>But in Debian they don't work with the 2.4xxx kernel with K3B, and scsi
>emulation make no difference other than vanishing the external device. It
>seems that growisofs eats the device if scsi emulation is used. There are
>some things on the Internet about this. K3B use eats the external USB Lite-On
>because /etc/fstab lists it as an scsi device.
>I cannot understand the growisofs way of creating a DVD, [more reading
>required] so burn CD's as backups. XCDRoast works a treat without any
>problems. Especially on the external Lite-On device.
>That may or may not help.....

What means K3B?

Well the funny thing is that the Lite-on LTR-24102B (internal) has
worked twice. The last occasion was when I used an initially written
multi-session CD-RW (Imation) under Windows-XP, containing just one
session. Adding another session to this CD-RW on my Linux box worked.
The added information could be accessed from this CD-RW on both my Linux
box and a Windows-XP machine!
So the behaviour is rather strange.

I'll have the CD-writer checked for possible malfunctions! But I don't
believe it to be a hardware problem!

Does anybody know what CD-writers definitely work with Debian Sarge 3.1
(kernel 2.4.27)?


To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Hi Gerard,

I came in late on this thread, so just ignore me if I am repeating anything thats already been said.
I had similar problems when starting with Sarge, kernel 2.4.27-1-386, and k3b as burnersoftware.

My CD-burner is:
Lite-On LTR48126S (I'm not at home so I'm guessing, but it is a pretty good guess)
After doing all the configurations listed below this burner has worked perfectly!!

If I should write a checklist on what I needed to fix, it would be:
    - SCSI emulation (couldn't burn a working cd without this!!!)
    - Set CDRECORD to SUID   (dpkg-reconfigure cdrecord)
    - listen to all errormessages you may see when starting k3b, and fix them!
    - Edit /etc/cdrecord/cdrecord so it  includes correct driver information.
                If you don't have this info, you can find burnerspecs on the web, use google.
                Sometimes it helps to set MAX_BURNERSPEED to less than the one given by
                the burner-specs. In my case I adjusted it down from 48x to 40x...
    - Set rights to all devices needed for the cd-burner (these can be more than just one...)
          with scsi emulation on my computer this was /dev/scd1 , /dev/sg1 , /dev/cdrw  (just a symlink),
          and make sure the devices is owned by a group you are a member of.

If you have done all this, it could also help to delete the k3b configfile (dont remember the path but it is on your HOME-directory under .kde/somthing/something/k3b.conf (or something like that)) and restart k3b...

You could also do an experiment if root-user can burn with k3b flaless. If so,
the solution is most likely in the list above, or something similar.

Good luck!! If you need detailed explenations on this, say so and I will hand it to you when
I am at home by the PC.

Cheers, Vegard

Reply to: