[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: mount: /dev/fd0 is not a valid block device

On Mon, Jan 24, 2005 at 09:23:21AM -0600, Kent West wrote:
> Ioana Glitia wrote:
> >Kent West wrote:
> >
> >>Can you still boot into your old kernel? If so, does the floppy work 
> >>there?
> >
> >It worked with pressing shift. I selected LinuxOld (that's how it 
> >named it) and the floppy worked just fine. Also I've put the bios to 
> >check the floppy and that gave me an ok answer.
> Hmm, fascinating. The floppy works with your old kernel, but not the new.
> I'm thinking you must be missing a module in your new kernel. We've 
> already tried "floppy".
> Folks, what else is she missing?
> What's the result of "ls -l /dev/fd0"? Here's mine:
> estk[@westk03]:/home/westk> ls -l /dev/fd0
> brw-rw----  1 root floppy 2, 0 Jan 24  2002 /dev/fd0
> What's the exact syntax of your mount command?
> What's the permissions on your mount point?
> As what user are you mounting the floppy? Is this user either root or a 
> user in the floppy group, or using sudo?
> What's the file format used on the floppy (FAT16, FAT32, ext2, etc)?
> Does "dmesg" have any info relevant to the floppy? "dmesg | grep fd" 
> should pull any relevant entries.
Hi Ioana and Kent,

I recall something in the kernel sources about floppies and IBM Thinkpads
(got an old Thinkpad myself)... this is an excerpt from the 2.6 kernel
documentation, but that might work as well for the 2.4 series:

<<< copied from the kernel source, Documentation/floppy.txt >>>
LILO configuration options (Thinkpad users, read this)

 The floppy driver is configured using the 'floppy=' option in
lilo. This option can be typed at the boot prompt, or entered in the
lilo configuration file.

 Example: If your kernel is called linux-2.6.9, type the following line
at the lilo boot prompt (if you have a thinkpad):

 linux-2.6.9 floppy=thinkpad

You may also enter the following line in /etc/lilo.conf, in the description
of linux-2.6.9:

 append = "floppy=thinkpad"

 Several floppy related options may be given, example:

 linux-2.6.9 floppy=daring floppy=two_fdc
 append = "floppy=daring floppy=two_fdc"

 If you give options both in the lilo config file and on the boot
prompt, the option strings of both places are concatenated, the boot
prompt options coming last. That's why there are also options to
restore the default behavior.


        Tells the floppy driver that you have a Thinkpad. Thinkpads use an
        inverted convention for the disk change line.

<<< end of copy&paste >>>

So you should either add a line into lilo.conf, so that it reads:

	<possibly more options>

(run the command "lilo" afterwards, so the changes get written to disk!),
or you should load the module later by hand using

modprobe floppy thinkpad

Please try that - if that doesn't work, I'd want to have a look at the
output of dmesg, lsmod, and the names of the old and new kernel packages
you installed. :-)

Hope this helps,

Jan Nordholz

PS: Sorry if this is a double-post, but I'm currently experiencing trouble
with my outgoing mail server, and my last try still hasn't shown up on the
list, although it's been hours since I sent it...

Jan C. Nordholz
<jckn At gmx net>

Attachment: signature.asc
Description: Digital signature

Reply to: