[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: mount: /dev/fd0 is not a valid block device

Kent West wrote:

Ioana Glitia wrote:

Kent West wrote:

Can you still boot into your old kernel? If so, does the floppy work there?

How can I do that? I don't have the package .deb for the old kernel (2.2) -- that came with the base -- on the computer, or at least not where I put all the .deb packages that I copied to the thinkpad. But I don't know where the base installed the kernel and put it, and how to boot into the old kernel.

Assuming you're using lilo to boot (as opposed to grub or something else entirely), you can probably press the left Shift key right after the Power-On Self-Test (POST), which , IIRC, should show you a menu of available kernels.

It worked with pressing shift. I selected LinuxOld (that's how it named it) and the floppy worked just fine. Also I've put the bios to check the floppy and that gave me an ok answer.

Alternatively, if you can boot from CD and you have a LiveCD (like Knoppix or Kanotix or Mepis, etc), just use that LiveCD to boot and see if the floppy works in that environment.

Well this little thing ( the thinkpad 755c) doesn't have a cdrom :) . I got it from my dad cause he doesn't want to use it anymore, he's got a new one. That's why I keep putting packages I need on floppies and them copy them to the harddrive.

I'm sorry, I suppose I'm more of a newbie when it comes to this.

'S'okay; we've all been there.

Thank you for being so kind.


Reply to: