[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: mount: /dev/fd0 is not a valid block device



Ioana Glitia wrote:

Kent West wrote:

Can you still boot into your old kernel? If so, does the floppy work there?

It worked with pressing shift. I selected LinuxOld (that's how it named it) and the floppy worked just fine. Also I've put the bios to check the floppy and that gave me an ok answer.


Hmm, fascinating. The floppy works with your old kernel, but not the new.

I'm thinking you must be missing a module in your new kernel. We've already tried "floppy".

Folks, what else is she missing?

What's the result of "ls -l /dev/fd0"? Here's mine:

estk[@westk03]:/home/westk> ls -l /dev/fd0
brw-rw----  1 root floppy 2, 0 Jan 24  2002 /dev/fd0

What's the exact syntax of your mount command?

What's the permissions on your mount point?

As what user are you mounting the floppy? Is this user either root or a user in the floppy group, or using sudo?

What's the file format used on the floppy (FAT16, FAT32, ext2, etc)?

Does "dmesg" have any info relevant to the floppy? "dmesg | grep fd" should pull any relevant entries.

--
Kent



Reply to: