[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: lpd doesn't work



On Sat, Sep 06, 2003 at 06:38:12PM -0300, Frank Hrebabetzky wrote:
> On Sat, 6 Sep 2003, Jason Chambers wrote:
> > A script which does "cat > /tmp/is-lpd-working" should prove the filter
> > is being called.
> >
> > Don't forget to get lpd to re-read /etc/printcap when you change
> > it though.
> 
> Did that. My printcap is now:
> 
> ##PRINTTOOL3## LOCAL uniprint 720x1440 a4 {} EpsonStylusColor740 Default {}
> lp|epson:\
> 	:sd=/var/spool/lpd/lp:\
> 	:mx#0:\
> 	:sh:\
> 	:lp=/dev/lp0:\
> #	:if=/usr/lib/printfilters/master-filter:\
> 	:if=/root/SysAdmin/printtest:\
> 	:PAPERSIZE=a4:\
> 	:DESIRED_TO=ps:\
> 	:PRINTER_TYPE=LOCAL:\
> 	:ASCII_TO_PS=YES:\
> 	:GSDEVICE=uniprint:\
> 	:RESOLUTION=720x1440:\
> 	:PS_SEND_EOF=NO:\
> 	:NUP=1:\
> 	:RTLFTMAR=18:\
> 	:TOPBOTMAR=18:\
> 	:TEXT_SEND_EOF=NO:
> 
> and /root/SysAdmin/printtest is
> 
> cat > /tmp/is-lpd-working
> 
> I rebooted linux to be shure that the alterated printcap is called, but

To avoid rebooting you should do a 'checkpc -f' which will check the
/etc/printcap - making sure that filters exists and are executable and
that spool directories exists (-f makes it create any spool directories
with right permissions rather than just complaining about problems).

Then a 'lpc reread' (or calling the init.d script with reload) will get
lpd to use the new printcap.

> the only new file in /tmp has the name masteUN4lyJ and the content:
> 
> Could not find requested printer:
> Could not find requested printer:
> Could not find requested printer:
> Could not find requested printer:
> No way to print this type of input file:              ASCII text

Odd.  Copied and pasted your printcap entry from the email and it worked
on my machine (I use lprng).  Have you tried lpq -v (use multiple v's
for even more output) it should show when it started the filter, what
its outcome was.

As you said in a previous mail that /dev/lp0 is working as you can copy
a text file to it and it prints then try a simple printcap entry with no
filter.

lp:
	:sd=/var/spool/lpd/lp
	:lp=/dev/lp0
	
If that doesn't work try posting the output of lpq -v back.

-- 
 .''`.  Jason Chambers <chambersj@thingy.org.uk> 
: :'  : Registered linux user #271693 
`. `'`  
  `-    http://www.debian.org/ - The Universal Operating System

Attachment: pgpMRGJRdhZrk.pgp
Description: PGP signature


Reply to: