[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: lpd doesn't work

On Sun, 7 Sep 2003, Jason Chambers wrote:

> To avoid rebooting you should do a 'checkpc -f' which will check the
> /etc/printcap - making sure that filters exists and are executable and
> that spool directories exists (-f makes it create any spool directories
> with right permissions rather than just complaining about problems).

My linux doesn't know that command. What package is it from?

> Then a 'lpc reread' (or calling the init.d script with reload) will get
> lpd to use the new printcap.

'reread' seems to be from lprng command, my lpc (lpr-ppd) doesn't accept
it. I tried 'lpc stop all' and 'lpc start all' instead and it worked.

> Odd.  Copied and pasted your printcap entry from the email and it worked
> on my machine (I use lprng).  Have you tried lpq -v (use multiple v's
> for even more output) it should show when it started the filter, what
> its outcome was.

the -v option isn't accepted by my lpq either. It seems the arguments in
favor of lprng are accumulating.

> As you said in a previous mail that /dev/lp0 is working as you can copy
> a text file to it and it prints then try a simple printcap entry with no
> filter.
> lp:
> 	:sd=/var/spool/lpd/lp
> 	:lp=/dev/lp0

Did that and it works. 'lpr <textfile>' produced output on the printer.

What now? Any hint how to test the filter?

Another option would be lprng instead of lpr-ppd. As I wrote earlier, I
tried it, but lprngtool crashed when I configured my printer. I depend on
it as long as I don't know how to create a printcap file for my printer
(Epson Stylus Color 740) by hand. The problem is printer-specific because
lprngtool didn't crash when I selected another printer. I don't remember
the exact error message, but it looked as if Tcl/Tk didn't like an empty
or missing string or option.

Frank Hrebabetzky	Tel.:     +55 / 48 / 235 1106
Florianopolis			  +55 / 48 / 9998 7686
Brazil			email:	  frankh@terra.com.br

Reply to: