[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Repartitioned, now can't mount root

I used Redhat 9 for a short while, and I remember now they used the
partition labels in the fstab file.  Due to the nature of my choice of
backup system, it got in the way and I had to edit fstab to set the
actual /dev/xxx names so it wouldn't find the label on the modular bay
disk on my laptop.

So, I was mistaken about "root" not being valid.

I'm not so sure how much I helped, but I'm glad it's working for you


On Fri, 2003-07-04 at 19:24, Ryan Heise wrote:
>  On Fri, Jul 04, 2003 at 04:03:11PM -0400, Bret Comstock Waldow wrote:
> > On Thu, 2003-07-03 at 20:18, Ryan Heise wrote:
> > 
> > > > When you "failed to mount" what command line or arguments did
> > > > you use?  What's "-t XXX", etc.?
> > > 
> > > I didn't use -t, just:
> > > 
> > > mount /dev/hda1 root
> Strangely, I just tried the exact same command this morning and it
> worked:
> # mount /dev/hda1 root
> !!!
> I wonder what this could mean?
> Anyway, now I can mount this partition! I opened up lilo.conf and found
> one mistake (changed install= from something like boot-menu.b to
> "menu"), fixed it, reran lilo and rebooted. Success!
> It sounds unlikely that the install= line would cause this. Would the
> cause of my problem more likely be something simple, like I forgot to
> run lilo after my last kernel upgrade? It was so long ago, I don't
> remember what I did. I "thought" I just upgraded and reran lilo
> itself...
> Thanks again,
> Ryan
bwaldow at alum.mit.edu

Reply to: