[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Repartitioned, now can't mount root

It's hard to know what the true cause of this problem is because:

1. my root partition may be too big (13Gigs) for my BIOS (GIGABYTE

2. I just tripped over my power cord.

I've been running Linux on this box without a problem for about 3 years,
and just recently repartitioned so that I have one big root partition
instead of a small boot partition and separate other partitions. I was
unable to find out whether my BIOS supported INTx13 (is that right?) and
didn't want to risk upgrading the BIOS. So I decided to just try a large
partition, and if/when lilo failed, I would upgrade the BIOS. Now it has
happened, and I'm getting "LI" at boot. However, now I can't even boot
into my DOS partition to run the BIOS upgrading software.

But before I even go down that path, here's something else: I tried
booting of the rescue CD. I couldn't boot in rescue mode because it
couldn't mount my root file system. Then I tried booting up the
installer and mounting my existing root partition, and it failed with:

Mount failed: Invalid argument

I can actually view all of the partitions in the partition table, but I
just can't mount the root partition. I can however activate my swap

Does this look like a hardware problem, or a disk format problem?



Reply to: