[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: spamassassin installation help



This one time, at band camp, Rich Puhek said:
> Or, add the following to /etc/apt/apt.conf:
> APT::Default-Release "woody";
> 
> 
> and add a mirror for unstable to sources.list
> 
> then do
>   apt-get update
>   apt-get install unstable/spamassassin
> 
> should get you the latest packaged SA. Someone is also building .debs of 
> the CVS snapshots, if you really want to be bleeding edge. See the SA 
> archives for details.
> 
> --Rich

This is doable, but the problem is with spamc - it depends on a newer
version of libc6 than what is in Woody.  This means that if you want to
install the spamc from unstable (which you must to satisfy the Depends:
for spamassassin) you have to upgrade libc6 as well.  I run Sid on one
of my boxes, without any real problems, but I wouldn't want it running
on a mail server.

I found it much easier to backport for Woody than to mix distros like
this, but YMMV.
-- 
 --------------------------------------------------------------------------
|  Stephen Gran                  | Support Mental Health.  Or I'll kill    |
|  steve@lobefin.net             | you.                                    |
|  http://www.lobefin.net/~steve |                                         |
 --------------------------------------------------------------------------

Attachment: pgpsSzxEW0Wnm.pgp
Description: PGP signature


Reply to: