[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Terminfo and emacs

Manoj Srivastava <srivasta@debian.org> writes:

> 	Can you expand on this? Which files are missing? As far as I
>  can see, when I reinstall emacs21, it re-downloads the .deb for me,
>  and installs it. (a script/log of the failure would be helpful too)

I'd have to reruin the insall now to typescript the whole thing. Not
sure I'm competent enough to do that without screwing it up again. But
here is the sequence and a simulation of the errors seen.

1) It all began with an attempt to build emacs from source.  I ran
   into troubles first with terminfo not being found (fixed by
   downloading termcap-compat) and then with missing X files.
   (Some of the X header files I think.  But didn't make a record of

   But since I am more interested in getting this install running in
   other ways I didn't pursue the source build.  I'll do that some
   other time.  Some one has posted all the xstuff needed to make a
   source build work.

2) Instead, I opted to download and install emacs21.  It went off
   without a hitch.  `apt-get' brought down emacsen-common and emac21, 
   Both were installed with no problems.

3) The troubles were all of my own creation.  I moved some of my own
   files into /usr/share/emacs/site-lisp.  But then decided to keep
   them separate from the official install by putting them in

4) Somehow in doing this, I scrubbed:
     cxref  debian-startup.el
     noweb-mode.el sawfish.el
5) I wasn't sure what all had gotten nailed so I thought to just
   reinstall to fix it... So ran `apt-get install --reinstall emacs21' 

   It quit with error code 2 and complained about the missing files
   noted above. But replaced all but the cxref and contents.

6) I then tried apt-get remove emacs21 followed by apt-get install
   emacs21.  Again it quit with code2 mentioning the files above.

7) Tried apt-get remove emacs21 and emacsen-common followed by
   apt-get install emacs21 and emacsen-common.  Again the errors
   indicated missing cxref especially.

8) Finally I looked around carefully for cxref (a directory) which
   hadn't really been rm'ed, just moved to the wrong location.
   Replaced it in /usr/share/emacs/site-lisp.

9) Ran apt-get remove emacs21 and emacsen-common followd by apt-get
   install emacs21 and emacsen-common.  Which worked with no errors.

> 	Umm, unless you have removed some files belonging to dpkg
>  itself, or packages marked essential (that is the definition of
>  essential -- packages without  which dpkg fails).

Apparently cxref/cflow cxref/cxref.el, were the cause of the problem
laid out above.  I don't think any of the files mentined here are part
of emacs source package, but are debian additions.

Reply to: