[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Printing problems

On Sat, Jan 12, 2002 at 09:07:01PM -0800, Jeff wrote:
> > echo "test" > /dev/dsp
> I'm confused...I thought /dev/dsp was a sound device.

Opps :) I meant lp0 but was thinking of something else..

> And yes, the kernel is setup right.  I posted the config in my
> original post.  I sure it's right because this was working not
> too long ago.
> I tried:
> echo "test" > /dev/lp0
> and it printed the word "test".

Ok - so kernel works and printer works...

> I then install groff and tried printing with magicfilter printcap
> and it printed "unknown device: pc13".  I then changed to the
> printcap you suggested earlier and tried to print with lpr and
> got nothing to the printer, and lpq showed the job in error.

It's gs then.. The filter is set up correctly but gs doesn't seem to
recognize pc13. I should have seen that before.

gs -sDEVICE=pcl3 is the setting used by gs... It works here in unstable
and woody.... [that device]

Maybe try reinstalling gs? If your printing stopped working after an upgrade,
maybe you need to upgrade it again [buggy package?]

Hope this helps,

Reply to: