[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Printing with Epson 880, CUPS, & unstable - landscape only

On Tue, Oct 02, 2001 at 07:08:25PM -0500, Oleksandr Moskalenko wrote:
| * dman (dsh8290@rit.edu) wrote:
| > Cool.  I think the
| > 
| > *LandscapeOrientation: Plus90
| > 
| > line the PPD is what does it.  The printer must default to landscape,
| > so the ppd tells the filter/driver to rotate the page by 90? so it
| > comes out portrait.  Try "Plus270" ;-) -- if you want the paper to come
| > out with the bottom of the page first.
|   Double cool. I guess reading the files helps :-)


| > (BTW, I've been trying to get a Canon BJC-610 running on the network
| > lately so I'm interested in seeing how the various things work in
| > cups.  I think I have a solution, but I can't test it until I go home
| > and have the printer to play with.)
|   Have you tried anything else? I've tried getting my laptop to print to
| a postscript printer attached to a WinNT 4.0 machine here at work, but
| nothing but the CUPS did the job. However, CUPS is taking a whopping 6Mb
| of laptop's precious 32Mb, so I've been looking for alternatives though
| unsuscessfully. I tried xpdq, but it just fails silently on me as the
| author of the only samba interface I could find on the web warned.

Ok, here's the details :

    o Canon BJC-610 inkjet printer, parallel port

    o The driver from Canon doesn't work over samba -- it *needs* the
        parallel port (it was originally written pre-win95 too).

    o win95/98 come with some MS drivers for the 600 and 600e.  I've
        had it set up with the 600e driver which works over samba but
        people are getting annoyed because the colors are wrong (too
        much cyan)

        (I also found out that samba in win95/98 is broken in such a
        way tht 98 *can't* share a printer to a 95 client for anything
        but text.  I must have the 95 box as the "server".)

    o for a recent print job I tried moving the printer straight onto
        LPT1 and using Canon's driver.  It keeps complaining about the
        paper thickness lever even though it is in the right place.
        (Once, but only once, when I switch the cable it worked but
        not again)

    o I downloaded ghostscript to my Debian box and tried printing --
        I can manually take PS input and get bjc output which I can
        cat to /dev/printers/0 and get the correct colors, etc, from
        the printer

    o I can do the same with gs on windows, but it is still a PITA

    (I'm using CUPS on my Debian box, hopefully I can get it to filter
    though gs automatically, then share it from there)

    o CUPS allows me to specify a filter using "*cupsFilter:" in a PPD
        (ok, I ripped the PPD file off from gs because it was tne only
        place I found one)

    o I can write a filter that is just a wrapper around gs

Current status :

    I specified a filter to use.  CUPS' error log shows that it tries
    to run it.

    I wrote the filter (an sh script) but it isn't working.  It works
    if I run it from the shell, but not when CUPS runs it.  It gives
    an exit status of 2.  ('gs' is the last command run, /bin/sh is

The next step is to determine what causes gs to give exit code 2.
Possibly it means the input was no good.  The example in the CUPS
documentation shows application/vnd.cups-raster as the input type to
the filter, but I am trying to use application/postscript.  I don't
see any raster to ps converter in the standard setup either.

I hope I didn't bore you too much with this :-).  If you have any
suggestion, they are most welcome.


Reply to: