[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Escribir partición ntfs daña arranque de Windows 7



El sáb, 18-06-2011 a las 14:34 -0300, JAP escribió:
> El 18/06/11 10:45, Odair Augusto Trujillo Orozco escribió:
> > El día 13 de junio de 2011 15:31, Javier Argentina
> > <javier.debian.bb.ar@gmail.com>  escribió:
> >> El día 13 de junio de 2011 16:59, Odair Augusto Trujillo Orozco
> >> <haldrik@gmail.com>  escribió:
> >>> El 13 de junio de 2011 06:40, Camaleón<noelamac@gmail.com>  escribió:
> >>>> El Sun, 12 Jun 2011 21:36:38 -0300, JAP escribió:
> >>>>
> >>>> (...)
> >>>>
> >>>>> Conclusión: si escribo desde
> >>>>> Linux amd64-debian 2.6.32-5-amd64 #1 SMP Mon Mar 7 21:35:22 UTC 2011
> >>>>> x86_64 GNU/Linux
> >>>>> a la partición ntfs
> >>>>> /dev/sda2: UUID="E6483F34483F02BB" TYPE="ntfs" el sector de arranque de
> >>>>> W7 se pierde. Por ahora, simplemente saqué el montaje automático de
> >>>>> fstab, UUID=E6483F34483F02BB   /media/ntfs    ntfs-3g
> >>>>> force,r,users,auto,utf8,umask=0    0    0 y uso un pendrive para pasar
> >>>>> datos de un sistema a otro.
> >>>>>
> >>>>> Lo que pasó, es curioso, pero no me cambia la vida; si alguien sabe de
> >>>>> algo, se agradece alguna pista de por qué sucede.
> >>>> Puedes hacer una sencilla prueba: crea una partición en windows que sólo
> >>>> contenga datos y comparte sólo esa partición en linux, a ver qué pasa. O
> >>>> cambiar las opciones de montaje (ese "force" me suena a que era un poco
> >>>> agresivo).
> >>>>
> >>>> No sería la primera vez que veo un windows que no arranca porque tiene
> >>>> algún archivo de inicio "corrupto" y los archivos se pueden llegar a
> >>>> corromper sencillamente tras un mal apagado o tras una mala "desmontada".
> >>>>
> >>>> Saludos,
> >>>>
> >>>> --
> >>>> Camaleón
> >>>>
> >>>>
> >>> A mi también me sucede pero no necesito escribir la partición
> >>> para que suceda. Estos son los pasos que sigo:
> >>>
> >>> 1. Instalo Debian
> >>> 2. Instalo Windows 7
> >>> 3. Recupero el Grub y con ello la entrada de windows en el grub
> >>>
> >>> Inicio por windows y empieza a fallar el inicio, algunas veces no falla
> >>> windows se reinicia como cuando se daña.
> >>>
> >>> Cabe señalar que desde que no recupere el grub, windows 7 sigue bien,
> >>> también que me pasó con windows Xp, y también que no creo que sea
> >>> culpa del orden de instalación.
> >>>
> >>> Mi máquina es un HP G60, esto no me sucedió en otro equipo al cual
> >>> le puse arranque dual.
> >>>
> >>> Por ahí vi ese problema en un foro de ubuntu y parece que era problema
> >>> de grub y según eso lo corrigieron, pero en debian sigue sucediendo.
> >>> --
> >>>
> >>> "LARGA VIDA Y PODEROSA."
> >>>                Blog de Haldrik
> >>>
> >>>
> >> Como dato ampliatorio, tengo otra máquina muy similar, con CASI
> >> idéntica instalación.
> >> La primer máquina, la del problema, es de uso familiar por lo que
> >> necesito que grub sea amplio.
> >> La segunda es de uso exclusivo mío, por lo que es mś "geek" en su
> >> funcionamiento.
> >> La diferencia es que el disco que tiene Win7 no está incluido en el
> >> grub, es decir, tengo que "presionar F11" al arrancar para seleccionar
> >> el disco con el que quiero iniciar. En esta máquina, Win7 nunca se
> >> descompuso, a pesar de leer/escribir la partición ntfs en cuestión
> >> desde GNU/Linux, siendo la cadena de montaje del fstab exactamente la
> >> misma, incluido el "force" que a Camaleón no le gusta ;-).
> >> Por lo que estimo apuntalaría tu teoría de "fallo en grub".
> >>
> >> JAP
> >>
> >>
> >> --
> > Yo estoy convencido de ello, es mas, aunque no he hecho la prueba
> > estoy seguro que si recupero el grub sin recuperar la entrada de windows,
> > escribo sobre la partición C de windows e incluso sobre la de sistema
> > de arranque de windows, luego uso el cd de instalación de windows
> > y recupero el cargador de windows, este mismo no se vería afectado
> > por haber escrito, el problema es del grub y mas me late que es problema
> > de que pone a cargar el windows faltandole alguna cosa. Lo duro aquí es
> > que aveces entra derechito.
> >
> Es así como lo detallas. No importa cuánto escribas en la partición ntfs 
> desde un Debian, que si luegos corres la consola de recuperación de 
> Win7, el disco está impecable.
> Es evidente que grub daña algo en el sector de arranque de Win7, pero 
> sólo eso.
> 
> JAP
> 
> 
> -- 
> To UNSUBSCRIBE, email to debian-user-spanish-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
> Archive: 4DFCE1AA.7070008@gmail.com">http://lists.debian.org/4DFCE1AA.7070008@gmail.com
> 
> 

Pienso que una forma de arreglar temporalmente tu problema hasta que sea
arreglado el bug de grub, puede ser arrancar utilizando el mismo loader
de Win 7 eso se puede hacer utilizando el comando dd y modificando algo
en Windows en el *.ini del arranque, realmente ahora no me acuerdo de
como hacerlo si encuentro la informacion de como se hace te la mando la
posteo pero en la web hay bastante de eso, esto lo use en WIN XP cuando
estaba empezando con linux y me daba miedo (no se pq) aintalar el LILO
me funciono bien


-- 
Salu2 Francisco
Santiago de Cuba, Cuba
bosito7@gmail.com
"La autocompasión por si mismo, solo trae la destrucción del ser humano"



Reply to: