[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problème build-dep et vlc





Le 18 septembre 2008 10:02, Bruno Muller <bruno@inertiacreeps.net> a écrit :
Hello,


Le mercredi 17 septembre 2008 à 23:58 +0200, Vincent MAUGE a écrit :

> Le problème dans mon cas c'est que apt-get build ne fait rien et sort
> en erreur. Au delà de mon problème de vlc, j'aimerai comprendre d'où
> vient le problème : mon source liste, un bug dans la définition du
> paquet ... ?

Pour simplifier, "apt-get build-dep vlc" installe les paquets indiqués
sur la ligne Build-Depends par la commande "apt-cache showsrc vlc".

Et je te parie que la version de debhelper demandée pour construire vlc
est supérieure à celle dispo dans etch.
Et c'est pour cela que apt-get build-dep ne fait rien.

Merci de cette réponse très clair. J'ai donc exécuté la commande apt-cache showsrc vlc et celle-ci affiche les informations pour plusieurs paquets (normal mon source.list contient les repository de etch, lenny sid et gérer par des priorités) . J'ai l'impression donc que apt-get build-dep regarde un peut tous les paquets dispo au lieu de prendre les infos du paquets installable sur mon système. Il y a une option pour forcer la version ?

Vincent


Reply to: