[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problème build-dep et vlc





Le 17 septembre 2008 23:30, Gilles Mocellin <gilles.mocellin@free.fr> a écrit :
On Wed, Sep 17, 2008 at 10:53:34PM +0200, Vincent MAUGE wrote:
> Bonsoir,
>
> je cherche à compiler vlc 0.9.2 depuis les sources sur ma debian etch. En
> suivant leur wiki, il propose la commande apt-get build-dep vlc pour
> récupérer les dépendances nécessaires à la compilation. Mais quand je lance
> cette commande j'ai l'erreur suivante :
>
> Reading package lists... Done
> Building dependency tree... Done
> E: Build-Depends dependency for vlc cannot be satisfied because no available
> versions of package debhelper can satisfy version requirements
>
> Je n'utilise normalement que des paquets de etch.

Et oui, mais pas pour le paquet source, sinon, ça ne serait pas la verion 0.9.2 !
Tu dois avoir une ligne deb-src dans /etc/apt/source.list qui pointe sur la version unstable.

Le paquet unstable dépend, pour sa construction, de paquet de unstable...

Là, tu entres dans les joies du backport.
- soit tu recompiles pour etch debhelper d'unstable. Et peut-être que ça entrainera d'autres dépendances...
- soit tu compile vlc à partir des sources, sans utiliser les outils debian...
 
La version de etch est la 0.8.6. Je veux justement compiler la 0.9.2 a partir des source mais je pensais que build-dep me faciliteraient le téléchargement les dépendances pour la compilation (Et ainsi éviter de lancer ./configure, regarder les erreurs et télécharger le packages correspondant jusqu'à qu'il n'y ai plus d'erreur)
Donc que fait exactement la commande apt-get buid-dep <un_nom_de_package> ?


Vincent

Reply to: