[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Instal failiures on a Macintosh LC475

On Tue, Sep 06, 2005 at 04:10:35PM +0200, Wouter Verhelst wrote:
> On Tue, Sep 06, 2005 at 06:55:22AM -0700, Yan Seiner wrote:

> > Using the testing installer, it crashes with can't get a pty: No such
> > file or directory.  If I let it run long enough, I get a fclose: no
> > space left on device.
> Yes, that's known; the daily builds for 2.2 are broken currently. We're
> working on it :-)

Interesting, I must've missed something because I didn't know about it.
I just tested hd-media from 2005-09-05 and the only problem I
encountered was keyboard related (which could be skipped). It's
currently installing base. 

It is possible that if you are creating a new partition, that it doesn't
end up showing up in /proc/partitions. A reboot usually fixes it and
formatting can be done normally after that.

I don't know why that happens sometimes.

> > I've tried both hdnative initrd.gz and initrd22.gz; same result.  I've 
> > tried increasing the ramdisk to 20MB; same result.
> > 
> > I am running on an LC475, 36MB RAM, 18GB hard disk (partitioned with a 
> > patched Apple HD SC).
> That should work

If you're using 2.2.25, you must use initrd22 (whether nativehd, 
hd-media, or cdrom shouldn't matter).

> > The machine will run linux; I have set up a minimal environment using 
> > busybox and I can netboot to it.  It runs fine.  Just the partition 
> > manager chokes on something on the hard disk/controller.
> > 
> > My kernel args are root=/dev/ram ramdisk_size=20000 mac53c9x=1.
> You want "mac53c9x=1,0". The install manual was wrong there; I've sent
> in a bugreport to get it fixed, but that hasn't happened for the sarge
> version of the manual yet.

Wouter: Thanks for that update.

Stephen R. Marenka     If life's not fun, you're not doing it right!

Attachment: signature.asc
Description: Digital signature

Reply to: