[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Instal failiures on a Macintosh LC475

I have been trying unsuccessfully to install Debian sarge and now debian testing on my old LC475.

The install goes well until it gets to the partitioning. Using the sarge installer, partman hangs at 72%. Using the testing installer, it crashes with can't get a pty: No such file or directory. If I let it run long enough, I get a fclose: no space left on device.

I've tried both hdnative initrd.gz and initrd22.gz; same result. I've tried increasing the ramdisk to 20MB; same result.

I am running on an LC475, 36MB RAM, 18GB hard disk (partitioned with a patched Apple HD SC).

The machine will run linux; I have set up a minimal environment using busybox and I can netboot to it. It runs fine. Just the partition manager chokes on something on the hard disk/controller.

My kernel args are root=/dev/ram ramdisk_size=20000 mac53c9x=1.

I have tried it with and without the last one; same result.

Any suggestions?

Or, does anyone have a minimal root fs for a mac tarballed somewhere? All I want to do is have this machine run rsync and ssh.



Reply to: