[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ZFS'ing my T5120 with Debian

On 23 May 2018, at 18:48, Chris Ross <cross+debian@distal.com> wrote:
> On Tue, May 22, 2018 at 10:56:49PM -0400, Chris Ross wrote:
>> Booting an installer may not work, though, since I need ZFS support in the
>> system I'm running.  To get a d-i with ZFS built in, I presume I'd have to
>> build my own.  Which I could, but don't know that I know how.  If I can use
>> something like debian-installer, I'd like to, but need one that can mount
>> up my ZFS filesystems.  Otherwise, I guess I need to find a guide of how to
>> do it the lower-level way.  ([1] looks valuable)
>> [1] https://github.com/zfsonlinux/zfs/wiki/Debian-Stretch-Root-on-ZFS
> Well, I tried running debootstrap, but I don't know how to point it somewhere
> for a ports installation.  I assume it should work, I just need the right
> URL to give it?  I tried all of:
> sudo debootstrap sid /z
> sudo debootstrap sid /z http://ftp.ports.debian.org/debian-ports/
> sudo debootstrap sid /z http://ftp.ports.debian.org/debian-ports/pool-sparc64
> sudo debootstrap sid /z http://ftp.ports.debian.org/debian-ports/dists
> sudo debootstrap sid /z http://ftp.ports.debian.org/debian-ports/dists/sid
> And it always fails the same way:
> I: Target architecture can be executed
> I: Checking Release signature
> I: Valid Release signature (key id 126C0D24BD8A2942CC7DF8AC7638D0442B90D010)
> E: Invalid Release file, no entry for main/binary-sparc64/Packages

The second command should work. Do you have gunzip or unxz in your PATH? You
need one of them for debootstrap to let you use that Packages.?? file, and
there's no uncompressed version.


Reply to: