[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sun Leo (ZX)

Martin Habets wrote:
Does the kernel detect the card when booting? You should see something
like the following when booting:
/sbus@2,0/SUNW,leo@2,0: leo at x:x
Also you should have leo ranges in /proc/iomem and /proc/ioport.

Ahhh... no, I don't see that in dmsg or anything in those proc files. I can see the driver enabled in .config and I think that I'm running the appropriate kernel but it's obvious that I need to go and check.

Am I correct in interpreting what you've said as meaning that X's "No devices detected" actually means "I'm not seeing the appropriate device support in the kernel"?

Seems this driver creates a normal fb device. Make sure you have /dev/fb0
and/or /dev/fb0autodetect.
You could try the fbdev X driver:
       Driver          "fbdev"
without specifying a BusID.
This is just to see if it detects a device. If it does the issue is with the
leo X driver. If it does not my guess it more toward a kernel issue.

Noted. Unfortunately the disc attached to the machine has started failing and is rapidly getting worse so that's something that's got to be tackled before I can progress this much further.

I'll be back, but I might be some time...


On Sun, Mar 09, 2008 at 07:17:49PM +0000, Mark Morgan Lloyd wrote:
Jurij Smakov wrote:
On Sun, Mar 09, 2008 at 04:01:40PM +0000, Mark Morgan Lloyd wrote:
(II) SUNLEO: driver for Leo (ZX)
(EE) No devices detected.

Fatal server error:
no screens found

I've tried several combinations of BusID etc. without success.
Can PROM/prtconf see this device? I guess that would give you the correct location, if any.

Best regards,
Yes, print-devs (?) shows it as /sbus@2,0/SUNW,leo@2,0 and I can see it in the /sys tree.

lssbus doesn't work on this system but I've never tried running it on 2.6 before- I need to check whether there's an updated version.

I don't believe there's a hardware problem since it displays the Sun logo with a Lion sitting on it when video first comes up, I do note however that it's a rather magenta Lion and that console text is very slow.

This is a sacrificial development machine and I'm quite happy to experiment on it. Which is fortunate since I tried installing Lenny earlier and am now getting "Fast data access MMU miss" [sigh].

For the record, that last was a red herring- I was saying "?" to OpenPROM rather than "help".

Mark Morgan Lloyd
markMLl .AT. telemetry.co .DOT. uk

[Opinions above are the author's, not those of his employers or colleagues]

Reply to: