[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Lenny on Ultra 60

Howard Eisenberger wrote:

I'm now running testing, vmlinuz-2.6.22-3-sparc64-smp on the U60. I installed alsa-utils and ran alsaconf, but didn't write to /etc/modprobe.d/. With only snd-sun-cs4231 in /etc/modules, lsmod
looks like this:

Module                  Size  Used by
snd_sun_cs4231 23568 0 snd_pcm_oss 52512 0 snd_mixer_oss 21056 1 snd_pcm_oss
snd_pcm                92108  2 snd_sun_cs4231,snd_pcm_oss
snd_timer              28496  2 snd_sun_cs4231,snd_pcm
snd                    65248  5 snd_sun_cs4231,snd_pcm_oss,snd_mixer_oss,
soundcore              11408  1 snd
snd_page_alloc         14416  2 snd_sun_cs4231,snd_pcm

and ls -l /dev/dsp* like so:

crw-rw---- 1 root audio 14, 3 2008-03-04 13:13 /dev/dsp

Sound seems to be working well as before using aumix or alsamixer
and ogg123, mplayer, vlc, etc.

I've verified that the hardware's OK by installing Etch which worked once I'd edited /etc/modules.

Running alsaconfig appeared to complete but didn't improve things- I tried both without and with updates to modprobe.d.

Same kernel version here I think, the ISO's a few weeks old though- 20080128-23:54. Full upgrade to latest package versions doesn't improve things, I've checked permissions etc. and don't see an obvious problem.

For the moment I'm reverting to Etch since I want this machine working- pain though because of the way the kernel crashes when it sees a serial break. I'll grab a clean Lenny ISO in a few days and at the very least will try to monitor progress.

Mark Morgan Lloyd
markMLl .AT. telemetry.co .DOT. uk

[Opinions above are the author's, not those of his employers or colleagues]

Reply to: