[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't boot linux on sun blade 2000

> >"Patrick Finnegan"
> > Has anyone gotten a version of 2.6 to boot on any Ultrasparc hardware?
> > I've been using the latest kernel (2.6.0 through 2.6.4) with the latest
> > toolchain in testing to compile it, yet it doesn't boot... the last time
> > I tried it, it spit out a bunch of whitespace to my serial console, and
> > then froze the machine (couldn't break back to OpenBoot).
> 2.6.x works fine on my Ultra10. The only issues are:
Was playing with Ben's compile of 2.6.3 on an Ultra 5 today.  To my
surprise (no disrespect to the tireless Ben - I've just been fighting
USB drivers of late) it worked first time :-)

> a) mouse does not work with X. This was mentioned on this list before
> b)ioctl32 problem with ALSA and CS4231, the box locks hard when snd-ioctl32
> module is loaded.
There is an ioctl32 problem period.  usbdevfs doesn't work fully -
anything involving URBs won't work[1].  The translation of structures
from 32 bit to 64 bit isn't complete.  I may take a look at it in a few
months as I oculdn't find anyone else saying they were working on it.


Sweet Dreams,
 - Martin

[1]. Just for the record - this means you can't use Speedtouch USB ADSL
modems on sparc64 :-(
"Seasons change, things come to pass"

Reply to: