[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: lilypond plans

On Sat, 2006-11-25 at 07:17 -0800, Steve Langasek wrote:
> Because lilypond 2.8.7 build-depends on guile-1.8, and lilypond *was*
> previously built on these architectures where guile-1.8 is unavailable.
> That still doesn't make 396119 release-critical.  It does make it a bug that
> has to be resolved for lilypond 2.8.7 to be released, AFAICS.

So we have a choice:

Accept a regression that the 64-bit archs will lose lilypond if we
switch to 2.8, or force all archs to have 2.6.

I think that, in view of the extreme oldness and badness of 2.6, it is
better to allow the non-released archs to suffer, in the interests of
making the release as good as possible.  Then, if guile-1.8 has the bug
fixed to allow it to work on the other archs, we can do a stable update
to add them.  (This is one of the primary reasons for stable updates,
after all.)


Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: