[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: lilypond plans

On Thu, Nov 16, 2006 at 07:05:01PM -0800, Thomas Bushnell BSG wrote:
> Currently lilypond 2.8.7 is in unstable.  It is blocked waiting for its
> own timelimit and for guile-1.8 to finish building on other archs and
> migrate itself.

Well, it's waiting for more than just guile-1.8 to "finish building", there
are guile-1.8 build failures on all the 64-bit architectures that need to be
resolved before lilypond can be built against it, which means lilypond will
be out-of-date on these archs until this bug in guile-1.8 is resolved.

This seems to have been filed as bug #396119.

> There is one more release in the 2.8 cycle, 2.8.8, which I have not
> packaged.

> Also, there is now 2.10.0, which I have packaged, but not uploaded.

> I wonder what is the best thing for me to do.  Most important to me is
> to get 2.8 into testing, though this may well be impossible.  Should I
> upload 2.10.0?

I wouldn't think that uploading 2.10.0 would be the best thing to do; your
best chances of getting lilypond 2.9 into etch are going to be to get
guile-1.8 sorted and let the current lilypond 2.8.7-2 slide in; if there's
time for uploads of newer upstream versions after that, all the better, but
I don't think there will be.

Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
vorlon@debian.org                                   http://www.debian.org/

Reply to: