[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Very Large Package Set Upgrade, stage 1

On Sat, Nov 25, 2006 at 05:51:27PM +0100, Luk Claes wrote:
> Bill Allombert wrote:
> > Dear release team,
> > 
> > Please find the result of the first VLPSU I conduced.
> > 3) the aptitude dist-upgrade output:
> > <http://people.debian.org/~ballombe/upgrade/aptitude.dist-upgrade.1>
> > 
> > The issue is that a lot of packages that are marked for removal that
> > should not be removed by the upgrade.
> In the case of aptitude most of the packages mentioned in the removal list
> should be removed AFAICS. In any case it looks remarkably good in comparison
> with the woody to sarge dist-upgrade!

I am not sure it looks any better. It seems x11-common is causing a
lot of breakage by having a versionned conflict on packages that
pre-depend on it. This create a chicken-and-egg problem and apt decide
to remove them rather than upgrading them.

The conflicts prevent to install x11-common before the upgrade.

Bill. <ballombe@debian.org>

Imagine a large blue swirl here. 

Reply to: