[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: issue booting CD iso on iBook G4

Hi John

John Ogness wrote:

Have you checked if the device is recognized? With the OF command
"devalias" you can see what usb0 is. For example, for me it is:


You can manually traverse the device tree and see if the USB disk is

dev usb0
ls   <--- should show an entry like "disk@1"

It did not! thanks for the trick...
OF didn't like my USB key (which wasn't USB3... but still). I had another one that worked.

boot usb0/hub@1/hub@4/disk@1:2,\install\yaboot

for me it was

boot usb1/disk@1:,\install\yaboot

and I did boot! I did use debian 8.11, since 8.9 was not readily available.

Then I booted the local disk by issuing

conf device=cd file=/install/yaboot.conf

<remove USB key !!>


Removing USB key is very important, or at boot it is detected and a mismatch happens between kernel and installer and, for example, no kernel modules are detected.

The ISO is still old, with the wrong mirrors! so only the packages of the ISO get installed

The installed, system does not boot. It loads the first stage.... but then resets.

I tried booting of from the USB, but I don't know where to get the system yaboot.conf from


On a side note, it is a bit frustrating that I provided a patch and even
NMU package [0] with a fix 3 months ago but because it is not being
accepted, people like you continue to waste our time on this issue.

Yes, indeed, a working yaboot would have saved me hours of time... the trick of usb load, the not recognized USB key.. and at the end, the trick of removing the USB key!

What a work. Including the obsolete mirrors :(

Reply to: