[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: G3 Beige Tower install with BootX - help

I know it's considered impolite on this list to top-post, but Nicholas' post is long and so close to perfect that it's worth leaving un-disturbed. I have only one thing to add to it:

Long ago when I was doing this frequently to test the (then very new) Sarge installer, by doing an "expert" mode install (setting "DEBCONF_PRIORITY=low" as Nicholas recommends), you could skip over the attempt to install quik by going to a step called (at the time) something like "proceed without a boot loader" in the main menu. This prevented the quik installer from destroying the boot-partition information in NVAM. So when the time came to reboot, you went directly into OS-9. There was no need for the "update Apple hard disk drivers" step with the OS-9 CD that Nicholas describes.

A lot of things have changed since Sarge, and this bit of lore may no longer be applicable. I'll try it out with Lenny myself on a spare disk, and report back.



PS: I've modified the subject a bit to get all the keywords in, so that it will be easier to find this discussion in Google the next time it comes up, a couple of years from now.

On Sep 8, 2008, at 5:41 AM, Nicholas Helps wrote:

Hello Stephen / all,

Here is a post I put on some time ago about this (Stephen, this is the post I mentioned). There is a preamble and then the step by step that worked for me. I have added a little bit about the space you will leave for Debian on your HD. This was not in the original post. You don't want to format that space using OS9, just leave it as free space and let the Debian installer do that for you. Good luck...


Hello all,

I have been working with Debian for quite a few years now and using powermac G3 machines with extra network cards in them as routers and firewalls, etc. These machines were set up back in the days of Woody and have been kept uptodate with security updates, but otherwise pretty much left untouched. Due to the issues around the firmware in these machines and because it was useful, I always set them up to boot initially into mac OS9 then use BootX to hand over the Debian. This worked a treat.

However, I thought it would be good come up to date by installing Etch instead. I used a free machine that was not actually in use and ran the install using the current network install ISO. Things have changed since the days of woody and it now seems that floppy images (boot image and root image) are no longer used. Hence, I copied the initrd.gz file over to the mac HD and set that as the ram disk for the install. I also copied across the linux kernel and put that into the kernels folder in the system folder. Using that allows me to boot into the installer and using the installer I deleted the previous linux partition (hda7) and swap (hda8) and made new ones. Then installed the base system, etc,etc all the way through to where it runs tasksel. I just leave that at the basic system for now. Following on some more, finally we get to the point of trying to install Quik (which I don't need) and it gives an error anyway, since I have selected ext3 file system that is not supported in quik. I therefore say to carry on without a boot loader. Everything goes fine all the way to rebooting into the new system. However, when I do that, OS9 will not boot up. I just get the flashing disk symbol with a question mark on it. Popping the OS9 CD and booting off that and then running disk setup shows me that the HD has somehow been altered so it is not recognised properly as a mac HD. During the partitioning step, I did not alter anything other than hda7 and 8.

I have found that I can reinstall the apple hard disk driver onto the disk and this then gets OS9 up and working. However, I cannot then boot into Debian, since the boot process gets a little way in and then I get a kernel panic at the point where it tries to mount the file system (error about no file system at /dev/hda7).

I have done this several times now and the same thing happens every time. The install goes fine but then I end up with a completely unusable machine.

I am wondering if I am going about the install process wrongly (ie using the initrd.gz file). I can't find anything really useful in the install manual or using Google. I will probably end up looking really stupid when someone points out an obvious mistake I have made, but I can live with that.

If anyone has got etch installed on the beige g3 (its a 266 mhz machine, but I can't tell you the firmware version, etc. Would need to find out how to get at this) and can share their expertise, it would be most appreciated.

Thanks in advance,


So, here is the way I got it to work....

First off, I have to thank Rick for a very helpful discussion about this. Without his help, I would not have been able to get this baby working!

I have OS9.2 on a circa 500 meg HFS+ partition, leaving the rest for debian (I will add here something I didn't mention in the original post - don't format this space using the OS9 CD, just leave it as "free space"). I use BootX as a boot loader. I used the netinstall CD for Etch.

First boot into OS9 with the Etch CD in the CD drive. Copy the vmlinux kernel from the CD install directory and put it into the kernels folder in the system folder. Copy the initrd.gz image to the BootX folder. Select the BootX application and tell it to use the vmlinux kernel and set the RAM disk to initrd.gz image. In the additional kernel arguments box, type "DEBCONF_PRIORITY=low" (no quotes). Boot into linux.

The installer will start. Go through this answering questions. When you get to the partitioning section, Partman will run. You should choose "manual" as your partitioning method. Select the free space and make a linux partition with Ext3 format and choose to mount "/" on it. On my machine this then becomes /dev/hda7/. Also make a swap partition (/dev/hda8). The sizes of these will depend on your HD size. You can also obviously choose to split up your file system so that not everything is under the root (/). I also named my /dev/ hda7/ as "debian". Probably makes no difference, but I did notice that the HFS+ partition (/dev/hda6) was called "untitled" as was / dev/hda7/ and did not think this a good idea.

Once you are happy with how the partitions look, write out the partition table. This will destroy the apple driver partition, but don't worry, you can recover from this providing you have your OS9 CD. More of this later...

Continue with the installation and install the base system and whatever else you want.

Despite being in the "expert" install mode, after install of the base system, the installer went straight into trying to install quik as the boot loader without giving me the option to avoid this. However, since quik only works with ext2 file systems, it bombed out with an error and allowed me to continue. I go all the way through to the point where it says the install is finished and wants me to remove the install CD and then select reboot. We stop at this point and swap to a new console (alt right arrow).

In here we can access the newly installed file system *and* the mac HFS+ partition. At the prompt, type "cd /" to make sure you are in the root of the file system. On my system, there was a folder at the root called "mnt" that contained nothing. I therefore typed in:

mount -t hfsplus /dev/hda6 /mnt

(note: I had put "/dev/hda7" here in the first post regarding getting Etch installed. hda7 on my system is actually the linux root partition. When deciding on which partition to mount here, the partitioning step will help, since partman lists the partition numbers).

This mounted the mac HFS+ partition under "mnt". You could use another directory, since mount just takes over the directory and then will give it back when you "umount", but I prefer to use an empty directory just in case.

Now you can cd to mnt and you should see your mac HD.

cd to /target/boot/ and cp whatever is symlinked to vmlinux and initrd (do a "ls -l" on the directory to see the details) over the mac HD.

Now "umount /mnt", change back into the installer console (alt left arrow) and remove the netinstall CD from the drive. Pop in your OS9 CD, because you will need it.

Reboot by selecting that option in the installer.

Your machine will boot into the OS9 installer (even without you holding down the "C" key). If you get a flashing disk symbol with a question mark in it, you have not got your OS9 CD in the drive. Remember that the partitioning has trashed the mac hard disk driver partition so your mac does not know what to do.

Once the OS9 installer disk has booted and you are at the window where you can choose to install OS9, go to the utilities folder and select drive setup. Once this has found the drives on your machine, select the one at the top (on mine it said "not mounted") and then select from the drop down menu at the top of the screen to "update apple hard disk driver". Once you do this, you get a message saying you need to reboot. Do this.

Now we can get back into OS9 on the hard drive.

Once in OS9, move the vmlinux kernel you copied above into the kernel images folder in your system folder. Put the initrd image anywhere you want.

Select the BootX application.

Select the linux kernel you just moved. Select "use specified ram disk" and choose the initrd image you copied above. Now in the additional kernel arguments box, enter "root=/dev/hda7" (without the quotes). Obviously your root file system might not be hda7, so change that appropriately. Save these settings to the defaults. You may want/have to enter other kernel arguments (eg for video), but I did not have to.

Now boot into linux.

BootX should hand over to linux and your new install will boot up. At least it did for me ;-)

If you upgrade to a new kernel / initrd image, you will need to mount the HFS+ drive and copy these over to it so that you can specify these in the BootX app.

Hope this has been of some use to someone.

Best of luck,



Dr. N.R. Helps
Medical Research Council Protein Phosphorylation Unit
College of Life Sciences
University of Dundee

t: 44 (0)1382 384745 (office)
t: 44 (0)1382 388019 (lab)
f: 44 (0)1382 388729
e: n.r.helps@dundee.ac.uk
w: http://www.dnaseq.co.uk/
w: http://www.ppu.mrc.ac.uk


Stephen Allen <sda2@sdf.lonestar.org> 09/07/08 6:18 PM >>>
On Sun, Sep 07, 2008 at 10:42:36AM +0300, risto.suominen@gmail.com wrote:
2008/9/7, Stephen Allen <sda2@sdf.lonestar.org>:

The install is where I had the issue(s), of going through the steps and
hanging when it came to installing
the quik bootloader. I don't understand why it's install quick as I thought
that BootX would be used.

You should try to skip the quik installation. The advantage of using
BootX is that if you use quik and it fails to boot you have no backup,
with BootX you can always get into OS 9. You don't need -  and cannot
have -  both: the OldWorld ROM always selects the first bootable
partition. Or - in theory - you could have quik in first partition and OS 9 in second and use quik to boot OS 9, but I don't see any point in

OK managed to skip the Quik installation. (I'll have to write up a SxS
mentioning how to do this)

I went through several iterations of disk partioning schemes without any
successful install. One message I
got several times was that Quik has to be on the first partition. The MacOS
has a small partition at the
first that doesn't delete for me, so I'm kind of stuck there.

You should keep the Mac OS partition. Get into another virtual
terminal (Ctrl- Alt- F2), mount the Mac OS partition (the path is either
/dev/hda... or /dev/bus/ide/disk.../part..., or similar):

OK kept the MacOS partition(s). There are 7 of em put there by the MacOS 9
disk utility (6 small ones).

I have one disk and it was labeled hdb when partioning. So that would be
'mount - t hfs (It's hfs)/dev/hdb7 (MacOS was installed on the 7th

There are a bunch of small Apple/MacOS partitions before this. But I assume since you mentioned system folder that it's has to go on the larger MacOS
partition where the Mac system folder is; correct ?

mount - t hfs /dev/... /mnt

(or hfsplus), and copy the new initrd into it:

cp - p /target/boot/initrd.gz '/mnt/System Folder'

There didn't appear to be an 'initrd.gz' but there was an 'initrd'. Same thing right ? On /mnt I didn't have a directory 'System Folder', however mount didn't through any complaints when mounting hdb7, so I assume that
was OK.

At this point you should have the kernel package installed on target

Unfortunately it didn't boot. I'm getting close though. Any ideas ?


-- Regards,
S.D.Allen -  Toronto

-- To UNSUBSCRIBE, email to debian- powerpc- REQUEST@lists.debian.org with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

The University of Dundee is a registered Scottish charity, No: SC015096

To UNSUBSCRIBE, email to debian-powerpc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: