[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems with Dial-up on Old World Mac

On Thu, Oct 26, 2006 at 06:46:09PM -0500, jrolland@wiremail.org wrote:
> I gave the commands you asked
> $ ps auxww | grep atalkd | grep -v grep
> root      1308  0.0  0.0  2028  688 ?        S    17:43   0:00
> /usr/sbin/atalkd
> $ lsmod | grep appletalk
> appletalk              43456  18
> and both appear to be working properly. I really believe that this problem
> has to do with network not being passed across the AsanteTalk - but I
> don't believe  the AsanteTalk is faulty (if that makes any sense). I think
> there's some black magic voodoo (like the init string with the modem) that
> I'm missing. The AsanteTalk works fine with Mac OS 8.6 and 10.4.8.
> One UseNet post I found claimed his AsanteTalk only worked with Linux if
> some traffic was passed over it first (via MacOS). The manual for the
> AsanteTalk claims that the AsanteTalk must be the last device started.
> While neither of these solutions worked for me, I believe it is something
> like this.

Well, it's possible that the AsanteTalk box doesn't properly handle a
local network that doesn't have a router seeding a net number and zone
name. The appletalk protocol is fully automatic from a normal client's
perspective, but zone handling requires a router seeding the correct
name. It might help to tell atalkd to act like a router. Take a look
at the manpage for atalkd.conf. I wouldn't be surprised if Apple's
official appletalk drivers detect this case and handle it a little
different from the way Linux does.

> One thing that may be useful to you is that when Debian starts, it claims
> it is starting AppleTalk (and that this may take a while). Then it claims
> that nbp_register (sp?) timed out trying to register
> computername:Workstation@* and something else (I didn't write it down, but
> I can try if it is relevant). Is this helpful?

I would guess that this error message indicates a problem with atalkd. If
you look at the startup script for netatalk, it does the following:

        # Start atalkd server.

        # register workstation
        /usr/bin/nbprgstr -p 4 "$ATALK_NAME:Workstation$ATALK_ZONE"
        /usr/bin/nbprgstr -p 4 "$ATALK_NAME:netatalk$ATALK_ZONE"

I would suggest checking the logs for any errors related to atalkd.

	Brad Boyer

Reply to: