[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems with Dial-up on Old World Mac

> On Wed, Oct 25, 2006 at 07:25:30PM -0500, jrolland@wiremail.org wrote:
>> The output of nbplkup is null. It doesn't appear to be sending traffic
>> though the localnet.
>> One interesting point is that I sometimes have my iBook running OS
>> 10.4.8
>> hooked up via ethernet to an ethernet switch (which the ethernet switch
>> is
>> then hooked up to the 7500 and to the AsanteTalk bridge) and I am unable
>> to see the iBook via nbplkup or any other means from  Debian, I am
>> unable
>> to see the Debian box from "Browse Network" in the iBook, but if I
>> choose
>> "Connect to Server" and input the Debian box's IP address in the iBook,
>> I
>> *am* able to log into the Debian box, which acts as an AppleTalk server.
>> I
>> dunno if that has any bearing, but just in case it might ...
> It's possible that you don't have the appletalk protocol setup correctly
> for some reason. The afpd process will run just fine and serve files over
> an IP based connection even without appletalk. Check to see if the process
> atalkd is running, and if the appletalk module is loaded into the kernel.
> $ ps auxww | grep atalkd | grep -v grep
> root      4051  0.0  0.0  2028  692 ?        S    Oct04   0:00
> /usr/sbin/atalkd
> $ lsmod | grep appletalk
> appletalk              54356  20
> 	Brad Boyer
> 	flar@allandria.com


I gave the commands you asked

$ ps auxww | grep atalkd | grep -v grep
root      1308  0.0  0.0  2028  688 ?        S    17:43   0:00
$ lsmod | grep appletalk
appletalk              43456  18

and both appear to be working properly. I really believe that this problem
has to do with network not being passed across the AsanteTalk - but I
don't believe  the AsanteTalk is faulty (if that makes any sense). I think
there's some black magic voodoo (like the init string with the modem) that
I'm missing. The AsanteTalk works fine with Mac OS 8.6 and 10.4.8.

One UseNet post I found claimed his AsanteTalk only worked with Linux if
some traffic was passed over it first (via MacOS). The manual for the
AsanteTalk claims that the AsanteTalk must be the last device started.
While neither of these solutions worked for me, I believe it is something
like this.

One thing that may be useful to you is that when Debian starts, it claims
it is starting AppleTalk (and that this may take a while). Then it claims
that nbp_register (sp?) timed out trying to register
computername:Workstation@* and something else (I didn't write it down, but
I can try if it is relevant). Is this helpful?

Thanks for your help.

Jeffrey Rolland

Reply to: