[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]


> On Tuesday 01 March 2005 08:14 pm, Tommy Trussell wrote:
> > ... on My "Wallstreet/PDQ" running sarge, I have trouble with
> > PCMCIA. In fact, when I put in a pcmcia card it gets HOT. 
On Tue, 1 Mar 2005 20:57:12 -0800, Dylan Beaudette <dylan@iici.no-ip.org> wrote:
> Hmmm... is this is 300Mhz Powerbook G3? thats what I have...

This is a PowerBook G3 Series 266 Mhz, aka "Wallstreet II" or "PDQ"
(Some people these "Wallstreet" because they look exactly the same,
but it actually has a few internal differences in traditional Apple
fashion.) I usually cover the bases by calling it a "1998 Wallstreet
266 Mhz." I believe your 300 Mhz model is also a PDQ:



> I am using a compact flash reader, and USB 1.1 PCMCIA card in my machine, and
> all seems to be working fine. Remind me, and i will post my relevant config
> files to the internet!
> I have not yet found a way to get the cards
> out, short of manually pulling them out... However, i think that the springs
> in my slots are getting worn, and I sometimes have to do this in MacOS...

I have inferred that on Wallstreet/PDQs, eventually the PCMCIA eject
cage breaks. (And of course the famous hinge clutch problem.) These
parts are still available as service parts some places, but I'd hate
to spend that much time and money to fix it... I am saying this as a
real cheapskate who has been loathe to spend the $145 it would take to
buy a new battery even though it would be nice. (The original battery
lasted almost five years, with the little use I put on it.) I also
need a new PRAM battery but what a hassle to get to THAT!

Anyway, the few times I tried the PCMCIA cards under linux I resorted
to using the paperclip eject holes. That technique works, but I gather
that you really want to be certain the card gets powered down
properly, too, so you don't damage the card or the slot with transient

> BTW, are you able to get sleep support on your machine.... also, what kernel
> are you using...

I have not tried sleep in awhile -- last I tried it would sleep
properly once and wake up and then not sleep again until after a
reboot. I'm always afraid to try it in a situation (like now) where I
could lose the train of thought in my email if the GUI crashes. After
I send this I will try again and if something has changed I will
report back.

I'm booting from the stock Debian 2.6.8-powerpc kernel from BootX --
though  apparently I have the 2.4.27 kernel installed too and that's
what apt has linked in the /boot directory (with the 2.6.8 files there
too). I can't remember now why I decided to run the 2.6.x kernel --
maybe it included hfs plus and the other didn't?

I have been trying to figure out if it's possible to get quik working
because it would be nice to give apt full control over the kernel that
actually boots the system. It would make compiling and testing a new
one much simpler!

I mention all this because it's very possible I have a configuration
problem because I have too much installed. Step one might be to remove
the kernel I'm not booting from....

> Since this is such a popular machine, perhaps it would be a good idea to pool
> all of our knowledge on this machine in some sort of web page... I would be
> happy to host it!

That would be good... there's lots of outdated information about
Wallstreets on the net... if my experience is any indication it's been
a very reliable linux machine, just difficult to get some particular
things working. And despite all the work I did with Ubuntu on
different machines a few weeks back I haven't even tried it on this
one. It would be very interesting to see how it handles it.

Reply to: