[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: yabootconfig fails on B&W G3

On Thu, Jul 11, 2002 at 12:09:26PM -0500, Kent West wrote:
> Kent West wrote:

> >The cp was successful, but the "ybin -v" produced the same errors.

It shouldn't have complained about the lack of a proc filesystem in the 
normal installer environment.
> So I started the installation over, and this time, during partitioning, 
> wiped the Apple Partition which gave me an empty drive, then created a 
> bootstrap partition (with the "b" command), created a 256MB swap 
> partition, and used the rest of the drive for a single / partition.
> When I got to the step to "Make System Bootable", I had the same 
> failures: yabootconfig failed. When I tried to run "yabootconfig" 
> manually on the second vt, it complained that it couldn't determine the 
> root partition.
> I'm really thinking there's something screwy about this particular G3's 
> hardware setup. I opened the case and took a look (didn't change 
> anything). The Maxtor hard drive is the only device plugged into the IDE 
> port on the mobo, and it's set to Master. The CDROM and zip drives are 
> plugged into the Ultra ATA port on the mobo.
> I've been trying to figure out how the aliases work, and it's not making 
> sense to me.
> According to "printenv", the "bootdevice" is set to "hd:,//:txbi", and 
> according to "devalias", "hd" and "ultra0" both are set to 
> "/pci/@d/pci-ata@1/ata-4@0/disk@0". BIG ASSUMPTION: I assumed that the 
> command "mac-boot" is equivalent to "boot hd:,//:txbi", so I ran that 
> command, and got the (by now, familiar) error "can't OPEN: hd:,//:txbi". 
> I tried it also with "ultra0" instead of "hd", and with the long name 
> (appropriately adapted).
> And since I've been able to boot the installation by referring to "ide0" 
> instead of "hd", it seems to me that "hd" doesn't refer to the hard disk 

Right. I think you just need to s/hd/ide0/ in all the documentation.

> at all. "devalias" refers to "cd" and "zip" and "ide0" as being on the 
> same controller ("mac-io/ata-3@20000", with the cd adding "disk@0" and 
> the zip adding "disk@1"). So "cd" is essentially the same as 
> "ide0/disk@0", but that can't be because when I boot the Debian 
> installation using a reference to "ide0", the installation starts from 
> the hard disk instead of the CDROM.
> So it seems to me that the aliases in OpenFirmware are messed up. I 
> tried a "set-defaults" command (or something similar; I found it on the 
> web yesterday but don't remember the exact command name), followed by a 
> "reset-all", which rebooted the Mac, but nothing changed.

I believe your hardware is set up on a different scheme than normal, re:
ide master/slave/primary/secondary.

> Related, sort of: Does setting the "Startup Disk" in MacOS simply change 
> the "boot-device" setting in OpenFirmware? In other words, could I 
> simulate changing the Startup Disk in MacOS with a command similar to 
> "setenv boot-device=[whatever makes CDROM vs Hard Drive, etc)?

I don't know, but I don't think so. It changes files on the hard drive
that the MacOS ROM reads at boot, I think.

*------v--------- Installing Debian GNU/Linux 3.0 --------v------*
|      <http://www.debian.org/releases/woody/installmanual>      |
|   debian-imac (potato): <http://debian-imac.sourceforge.net>   |
|            Chris Tillman        tillman@voicetrak.com          |
|                   May the Source be with you                   |

To UNSUBSCRIBE, email to debian-powerpc-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: