[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#599879: live-helper: Live Builder does not create the user account

On Tue, Oct 12, 2010 at 3:10 AM, Daniel Baumann <daniel@debian.org> wrote:
> On 10/12/2010 11:40 AM, Jose R R wrote:
>> I believe you missed (above):
>> I *explicitily* specified an user name of my own that I could grep in
>> config/* files.
> it does not matter how you name the user, the user is still created at
> runtime when you boot the image, not when you build it.

Assuming an user that I *especified* as: "name-of_user", below is how
I find it *and* I expect (if I understand the instructions
appropriately) to be created in the final image. This is how I would
check for its existence in the config/* resources:

$ find debian_live/config/ -type f | xargs grep -i name-of_user

debian_live/config/binary:# (Default: name-of_user)

Accordingly, if the "name-of_user" is not created in the final image,
as it happened in my initial attempts, then something is wrong -with
Debian Live scripts, the repositories, who-knows, etc.; but something
is wrong. I replied to Juan how the problem was resolved from my
perspective -in practical terms not in pedantic or theoretical ones.

>> I think you missed prior emails regarding issues of hard copy only
>> working on developing machine but failing in other where there is a
>> Fedora and Debian operating systems installed.
> i apparently did miss that too, do you have a reference?

At the risk of further hijacking this thread this is what the previous
email referenced:

Subject: Debian live binary-hybrid.iso to CD-Media hangs (October 8, 2010)

...ok, using

live-build                2.0.2+20101002.080418~50lenny+1
live-config              2.0.8+20101002.081229~50lenny+1
live-config-sysvinit  2.0.8+20101002.081229~50lenny+1

 to create the image and subsequently burn to CD-media; upon booting
machine other than host I can at last see the message where the hang
Starting MariaDB database server: mysqld........
[151.400003] BUG: Soft lockup - CPU#0 stuck for 64s! [rs:main Q:Reg:1297]
[216.896004] BUG: Soft lockup - CPU#0 stuck for 64s! [rs:main Q:Reg:1297]
[282.396003] BUG: Soft lockup - CPU#0 stuck for 64s! [rs:main Q:Reg:1297]
[347.896003] BUG: Soft lockup - CPU#0 stuck for 64s! [rs:main Q:Reg:1297]

>> I have asked for help and I have provided help to another user who
>> experienced similar issues that I experienced before. Whether or not
>> the answers to that user are pedantically accurate or not *that*
>> procedure helped me resolve *that* problem that the user is asking for
>> help.
> we were just pointing out that what you were doing did not solve it, but
> the time passed in between must have fixed it (because live-config 2.0.7
> migrated). not more, not less.
>> By selecting the Debian Live
>> scripts *all* I want is to create a Debian distribution with an LAMP
>> stack and an web application *that* boots in different hardware.
> and we're glad to assist you in acchieving that. maybe you come up with
> the actual *remaining* problems you're currently having in order to get
> it done?

Booting issues in other than the Debian Live host machine?

See the above reposting from Subject: Debian live binary-hybrid.iso to
CD-Media hangs (October 8, 2010)

>> ... then probably this is the wrong place to ask and resolve issues
>> since criticism of existing issues -for whatever reason- is highly
>> questioned. I should consider the SuSE Studio appliance builder, then?
>> http://susestudio.com/
> please feel encourage to find the right tool for what you like to do. it
> might very well not be debian-live, or it might, i don't know.

Thank you, I am beginning to consider alternatives.

Best Professional Regards

Jose R R
IBM Lotus Symphony supported on GNU/Linux, Mac OS, and Windows.
Daylight Saving Time in USA & Canada starts: Sunday 08 March 2010

Reply to: