[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: kernel 2.6.19 + Cisco 350 Wireless adapter needs manual config

Florian Reitmeir wrote:

On Fre, 12 Jän 2007, Mauro Darida wrote:

On Friday 12 January 2007 18:41, Florian Reitmeir wrote:
thats clearly a bug of UDEV. I suggest you purge
and delete the /etc/udev /etc/hotplug
(a backup is always nice)
and then make a fresh reinstall of udev.
ifrename it is not installed on my system; I did what you suggested and now my card is not recognised at all. Tried also modprobe airo with no results.
Noticed the following message at boot-up:
/etc/udev/rules.d/z99_hal.rules: no such file or directory

Any suggestion?

you really did a
dpkg --purge udev
dpkg --purge ifrename
dpkg --purge hotplug

if you did correctly and reinstalled udev everything should work normally
and the files should not missing anymore.

ok here .. in commands ..

apt-get --purge remove udev ifrename hotplug
rm -Rf /etc/udev
apt-get install udev hald

I do not know if this will help but I get a slightly older kernel running with this adapter. I have to admit even if I'm not yet under 2.6.19, I'm currently under Etch 2.6.18-7. Anyhow I faced to a very annoying issue with a HP Laptop Omnibook900 and exactly the same Cisco 350 Wireless adapter. When using the Debian package linux-image package (2.6.18-7) from Debian the pcmcia card is configured an work like a charm.

But when I do use my own compiled kernel I have always the same problem (I have tried many .config w/o any success): - The card is recognized in both cases (Yenta CardBus Bridge) and I do have equivalent tons of kprintf messages with my compiled airo module I always have the following:

airo(eth0): BAP error 4000 0
airo(eth0): Bad size 2630
airo(eth0): BAP error 4000 0
airo(eth0): Bad size 2636
airo(eth0): airo: BAP setup error too many retries

I look at any possible Google tips prior getting here asking stupid
questions. At cisco web side it's all now protected and inaccessible the
other available driver on sourceforge project page seems to have been
I'm alone in that case? Anyone could assist me with a working suggestion?

Or may be I'm just facing to one of the numerous licensing issue Debian could have with Cisco/Aironet?

Thanks in anticipation,

Reply to: