[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Hot CPU after hibernate (Dell Inspiron 4100)

Scott Bigham wrote:

> On Wed, Nov 23, 2005 at 10:38:25AM -0800, Ian Greenhoe wrote:
> > Is there evidence of a lot of processes being created?  (If you run
> > ps twice in a row, are the PIDs relatively close to each other?
> > Relatively close == within about 4 on a lightly loaded machine.)
> Almost identical.
> > Another thought is to try killing applications/daemons until your
> > CPU stops getting hot (as a diagnostic.)
> I tried killing off everything I thought I could get away with, to no
> obvious effect.
> > I suspect that if you track it down to a process (or two), you will
> > find that there is some common thread where they are using some part
> > of your hardware before you hibernate, and they are getting really
> > confused due to the hibernate (and they will need to be restarted
> > after hibernation).  My machine has a problem with XMMS in that
> > regard:  Anything that is actively using the sound when I hibernate
> > will not be able to use the sound after hibernating (until I restart
> > the offending process.)
> (nod) On a hunch, I tried adding the NAS deamon to the RestartServices
> line in hibernate.conf, but that didn't help.
> On Tue, Nov 22, 2005 at 10:42:47PM -0800, Graziano Obertelli wrote:
> > the load average above 2 doesn't seem to agree with the machine been
> > idle.
> (nod) I checked that:  immediately after resume, the load average is
> high (I've seen it above 4), but after a while it goes back down to
> zero if I leave it idle, and the temperature is still acting up.
> > Do you have kernel panics  (dmesg)?
> Not that I could see.  I've attached the output of dmesg, with the
> suspend/resume point marked.
> > Have you tried to remove some of the modules (wireless usb ...) to
> > see if they print errors?
> You mean rmmod?  Yeah, I tried removing everything I thought I could
> get away with (that it would let me rmmod, at least), to no obvious
> effect.  I've already got hibernate configured to unload
> "blacklisted" modules, which appears to include usb, and I shouldn't
> have any wireless modules loaded when the card isn't installed.  I
> tried setting UnloadAllModules in hibernate.conf, but not only did
> that not appear to help, it weirds the display on resume (well, I'm
> not entirely sure of that causality; the system was kind of hot at
> that point, and I may have been changing other settings at the same
> time).
> One other possibility I've come across in my further research is a
> BIOS upgrade.  I'm currently running revision A03, and there's an A13
> upgrade available from Dell.  I've been putting it off as long as
> possible, though, on grounds of nervousness; I haven't been able to
> find confirmation that A13 works with Linux, and AIUI, if you botch
> the BIOS, there's nothing left to fall back on.  That'll probably
> have to be my next step, though.
> 						-sbigham

I would definitely consider a bios upgrade.  I have a dell inspiron
4100 but I don't recall ever running at the A03 level but I must have.
My inspiron will not do ACPI reliably and things go terribly awry when
I try to use ACPI so I always just back off and go back to APM.  I have
the A013 bios here running with Linux and it works pretty well.  But
even with the latest bios, ACPI has never really worked for me reliably.

I've read reports of successes on various sites for using ACPI with a
4100 but its never worked for me.

I understand the nervousness but I would definitely consider moving up
to a new BIOS revision.

Michael Perry | Do or do not. There is no try --Master Yoda
mperry@lnxpowered.org | http://www.lnxpowered.org

Reply to: