[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Xircom RealPort modem(/eth) not working



On Sat, Sep 25, 1999 at 11:49:43PM +0000, Mark Phillips wrote:
> Hi,
> 
> I've recently installed Debian on a Toshiba Tecra 8000.  I'm trying to
> get a Xircom RealPort Ethernet + Modem card working.
> 
> I've compiled my own kernel (2.0.36) along with my own pcmcia modules
> package.  I notice that "hot swap" doesn't seem to work.  That is,
> when I push the card in or take the card out, the kernel doesn't seem
> to recognise that anything has changed.
> 
> But fortunately running "/etc/init.d/pcmcia restart" seems to cause
> the card to be recognised.  I then have tried to use the modem.  When
> I use pon, plog waits for expect (OK) but never gets it!  I thought it
> was because maybe /dev/ttyS0 was the wrong serial port, but no, even
> when I change it to /dev/ttyS1 it doesn't work.
> 
> Does anyone know what's wrong?

The pcmcia utils - I had no luck with the 3.0.14 - Instead i debianized
the 3.1 pcmcia utils and those worked flawlessly ...

Currently running Toshiba Tecra 8000 and an IBM Thinkpad 390 with
the Cardbus Realport 10/100 + Modem without any problems ...

I worked around the 3.0.14 pcmcia utils bugs by using the 
cardctl utility and suspending and resuming the cards. Afterwards
they were detected ok ...

Flo
-- 
Florian Lohoff		flo@rfc822.org		      	+49-5241-470566
  ...  The failure can be random; however, when it does occur, it is
  catastrophic and is repeatable  ...             Cisco Field Notice


Reply to: