[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: CRITICAL: Don't remove kernels 2.4.x, anybody upgraded hsflinmodem to 2.6.x?

On Sat, Jul 23, 2005 at 12:52:33AM +0200, svante@imit.kth.se wrote:
> Apparently, according to Francesco P. Lovergine , the latest version of
> hsflinmodem (5.03.27) was not free at all, it was a beta. Can anybody
> confirm this, since both 5.0327lnxbeta and 5.0327 versions exist... 

AFAIK they are the same one: CHANGES file contains:

Sun Apr 27 2003 Marc Boucher
        * Released hsflinmodem-5.03.27lnxtbeta03042700.

BTW, there are tons of binary or semi-binary only drivers out there
which work with 2.4 series only. I can point the Nokia D211 PCMCIA card
for instance, which has basically the same problem. Indeed, the right
thing to do is massive ranting with the vendor. When they have not either 
energy not intention to support their own devices, they should simply
release freely information and possibly code, and leave them to the
community. This case is a bit peculiar, because an up-to-date module
is indeed available at a symbolic cost (even if partially closed). 
Surely better than the Nokia case and many others, but not so much better.

Francesco P. Lovergine

Reply to: