[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [Live-demo] Let's bring the OSGeo live packages to debian!

Hash: SHA1

Il 11/09/2014 09:42, Andreas Tille ha scritto:

> Good that you asked since I was about to do it myself:  OTB is
> waiting for more input from you and other otb developers.  I'm just
> idling since

I think the package was OK, I was unable to configure QGIS properly to
use it. See my attached messages.
I'm willing to do more testing if I get some feedback (I'm rather
stuck at this point).
Thanks a lot.
Il 05/08/2014 09:45, Andreas Tille ha scritto:
> Hi Paolo,
> On Tue, Aug 05, 2014 at 08:08:10AM +0200, Paolo Cavallini wrote:
>> Sorry I was unclear. QGIS needs, for its core plugin Processing,
the setup of the
>> paths to the programs called (see [0]). It would be good to
>> preset
it while
>> installing OTB. The file is ~/.qgis2/processing/processing.conf
>> but
probably these
>> can also be configured system-wide.
> Besides the other hint to /etc/skel I would like to remember that
> a package is not allowed to deal with ${HOME}.  So either there is
> some generic way to configure (for instance some file in /etc/qgis2
> you could link to from users home dirs) or users are left alone to
> maintain their

Hi Andreas,
I'm forwarding this to Processing dev, to see if this can be changed
Hopefully we'll have qgis+saga+otb working out of the box then.
All the best.
Il 04/08/2014 19:06, Paolo Cavallini ha scritto:
> Il 04/08/2014 18:57, Paolo Cavallini ha scritto:
>> Hi all. I'm now testing the deb packaging of new (4.0) OTB. I
>> keep on
getting an error:
>> OTB execution console output 
>> /usr/bin/otbApplicationLauncherCommandLine: error while loading
shared libraries:
>> libOTBWrapperCommandLine.so.4.0: cannot open shared object file:
>> No
such file or
>> directory
>> What are the dir to add to config? More generally, which files
should I look for?
>> I have: /usr/lib/otb/libOTBWrapperCommandLine.so.4.0 Thanks.
> BTW, this does not work:
Thanks Giovanni. I tried again on 2.4 and a clean --configpath, and I
get the same error.
Problems also with saga: I had to enable 2.1, but then I get the error:

library path: /usr/lib/x86_64-linux-gnu/saga/libio_gdal.so
library name: Import/Export - GDAL/OGR
tool name : GDAL: Export Raster
author : O.Conrad (c) 2007

Load grid:
GDAL: Export Raster: could not initialize data objects

- -- 
Paolo Cavallini - www.faunalia.eu
QGIS & PostGIS courses: http://www.faunalia.eu/training.html
Version: GnuPG v1


Reply to: