[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

slapd configuration

Hello list, friends

Did anybody test the new ldap configuration for lenny on debian-edu?
my test result:
On a clear lenny instalation, I have installed debian-edu-install ( 0.669
ver.) and debian-edu-config ( 1.419~svn41038~edu.lenny+1) packages. Then,
i've installed slapd package using slapd presseds which are in
debian-edu-install package. I have got ldap server configuration from

I have run, according from cfengine tasks in cf.ldapserver:

- /etc/ldap/slapd.conf  -> /etc/ldap/slapd-lenny_debian-edu.conf
- /bin/chown openldap:openldap /etc/ldap/ssl
- /bin/chown openldap:openldap /etc/ldap/ssl/slapd-cert.cnf
- /usr/bin/mkslapdcert
- /bin/chown openldap:openldap /etc/ldap/ssl/slapd.pem
- /bin/chown openldap:openldap /etc/ldap/ssl/slapd-cert.cnf
- /usr/bin/ldap-debian-edu-install

1) it seams slapd server is running ok:
# ps aux |grep slapd

openldap 11125  0.5  1.0  21792  5464 ?        Ssl  18:04   0:00
/usr/sbin/slapd -h ldap:/// ldaps:/// -g openldap -u openldap -f
/etc/ldap/slapd.conf -4

2) slapcat and salpadd works ok. In fact i have a dump of ldap database
and it is right.

3) if I run ldapadd, the command fail:

tjener:~# ldapadd -x -h localhost -W  -D
"cn=admin,ou=People,dc=skole,dc=skolelinux,dc=no" -f usuario.ldiff
Enter LDAP Password:
ldap_bind: Confidentiality required (13)
	additional info: confidentiality required

well, with -Z option (TLS)

tjener:~# ldapadd -Z -h ldap -W  -D
"cn=admin,ou=People,dc=skole,dc=skolelinux,dc=no" -f usuario.ldiff
Enter LDAP Password:
SASL/DIGEST-MD5 authentication started
ldap_sasl_interactive_bind_s: Invalid credentials (49)
If I run ldap-server of testsuite, last ouput lines shown this error:
info: ./ldap-server: slapd.pem: error 18 at 0 depth lookup:self signed

is there something wrong on ldapadd command lines or slapd configuration?


Reply to: