[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian Installer 7.0 Beta1 release

On Mon, 2012-08-06 at 10:26 +0200, Julien Cristau wrote:
> On Sun, Aug  5, 2012 at 12:54:16 +0000, Sam Morris wrote:
> > I figured it out. The instructions at <http://www.mesa3d.org/
> > llvmpipe.html> seem to work. I had some difficulty getting 
> > LD_LIBRARY_PATH to stick, however... setting it from a script in /etc/X11/
> > Xsession.d doesn't work as it's reset by the time I log in. Eventually I 
> > logged in to a virtual console, set the variable, fired up X by hand and 
> > ran gnome-shell. The result is very buggy. I don't know if that's because 
> > mesa 8.0.4 (or one of its build dependencies) is too old, or whether 
> > something is being built wrong.
> > 
> A few things I can think of:
> - f17 seems to build against llvm 3.0, we use 2.9
> - there's a few patches in
>   http://pkgs.fedoraproject.org/cgit/mesa.git/tree/?h=f17 if updating
>   llvm isn't enough.
> I'd be interested in the results.
> Cheers,
> Julien

IIRC I built mesa with 3.0. I'll take a look at the patches. I also just
realised that I didn't run the X server with LD_LIBRARY_PATH set... is
that a problem, or is it just the clients that need the llvmpipe
libGL.so.1? Sorry for the dumb question, but my understanding of how all
the different bits of mesa/dri fit together is rather poor...

Sam Morris <sam@robots.org.uk>

Reply to: