Re: Please test eglibc 2.9-23+multiarch
On 2009-07-28 19:44 +0200, Aurelien Jarno wrote:
> I have recently uploaded to experimental eglibc 2.9-23+multiarch, from
> our multiarch branch. It doesn't use the multiarch paths yet, but it is
> a first step toward multiarch.
> The only difference with the unstable version is that libc-bin and
> libc-dev-bin are splitted out of libc6 and libc6-dev. This way it
> complies with the Debian Policy requirement that the libraries should
> not contain binaries, which is also a requirement for multiarch.
> Please test it and report possible problems related to this package
> split. If no problem are detected, it will be uploaded to unstable as
> soon as the current version migrates to testing. This way it will leave
> space in experimental for eglibc 2.10.
> Note that it is currently not yet available on all architectures, please
> wait for the experimental buildds to do their jobs.
I was not patient enough for that and built the packages myself instead
on i386. The result is not quite satisfactory, in a Lenny chroot they
cannot be installed due to a dependency cycle:
| # cat /etc/debian_version
| turtle:/# LANG=C apt-get dist-upgrade
| Reading package lists... Done
| Building dependency tree
| Reading state information... Done
| Calculating upgrade... Done
| The following NEW packages will be installed:
| The following packages will be upgraded:
| libc6 libc6-dev locales
| 3 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
| Need to get 0B/13.9MB of archives.
| After this operation, 6042kB of additional disk space will be used.
| Do you want to continue [Y/n]?
| WARNING: The following packages cannot be authenticated!
| libc6-dev locales libc6 libc-bin
| Install these packages without verification [y/N]? y
| E: Couldn't configure pre-depend libc-bin for libc6, probably a dependency cycle.
Same problem with aptitude, and this is the reason: libc6
2.9-23+multiarch Pre-Depends on libc-bin (= 2.9-23+multiarch) which in
turn Depends on libc6 (>> 2.9), so if you didn't have libc6 2.9-x
already installed, you're hosed.